summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/scikits_learn/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/scikits_learn/files')
-rw-r--r--sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch b/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch
new file mode 100644
index 000000000000..96c6cc2dbde5
--- /dev/null
+++ b/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system-cblas.patch
@@ -0,0 +1,28 @@
+--- sklearn/setup.py.orig 2013-08-08 13:54:08.310879167 -0700
++++ sklearn/setup.py 2013-08-08 13:52:59.808456423 -0700
+@@ -68,14 +68,6 @@
+ libraries=libraries,
+ )
+
+- # some libs needs cblas, fortran-compiled BLAS will not be sufficient
+- blas_info = get_info('blas_opt', 0)
+- if (not blas_info) or (
+- ('NO_ATLAS_INFO', 1) in blas_info.get('define_macros', [])):
+- config.add_library('cblas',
+- sources=[join('src', 'cblas', '*.c')])
+- warnings.warn(BlasNotFoundError.__doc__)
+-
+ # the following packages depend on cblas, so they have to be build
+ # after the above.
+ config.add_subpackage('linear_model')
+--- sklearn/_build_utils.py.orig 2013-08-08 14:01:35.994589269 -0700
++++ sklearn/_build_utils.py 2013-08-08 12:19:41.875967870 -0700
+@@ -23,7 +23,7 @@
+ return False
+
+ blas_info = get_info('blas_opt', 0)
+- if (not blas_info) or atlas_not_found(blas_info):
++ if (not blas_info):
+ cblas_libs = ['cblas']
+ blas_info.pop('libraries', None)
+ else: