summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/starparse/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/starparse/files')
-rw-r--r--sci-libs/starparse/files/starparse-1.0-guile1.8.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/starparse/files/starparse-1.0-guile1.8.patch b/sci-libs/starparse/files/starparse-1.0-guile1.8.patch
new file mode 100644
index 000000000000..1d6e176b079e
--- /dev/null
+++ b/sci-libs/starparse/files/starparse-1.0-guile1.8.patch
@@ -0,0 +1,60 @@
+--- src/guile-binding.c
++++ src/guile-binding.c
+@@ -61,10 +61,10 @@
+ char* filter_string = NULL;
+ char* fname = "-";
+
+- if (SCM_NFALSEP(filter_string_scm))
++ if (scm_is_true(filter_string_scm))
+ filter_string = scm_to_locale_string(filter_string_scm);
+
+- if (SCM_NFALSEP(fname_scm))
++ if (scm_is_true(fname_scm))
+ fname = scm_to_locale_string(fname_scm);
+
+ ship_item_cb = ship_item_scm;
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -6,13 +6,10 @@
+ libstarparse_la_SOURCES =\
+ parser.y lexer.l starparse.h
+
+-libstarparse_la_CFLAGS =
+-libstarparse_la_LDFLAGS =
+-
+ if ENABLE_GUILE
+ libstarparse_la_SOURCES += guile-binding.c guile-compat.h
+-libstarparse_la_CFLAGS += @GUILE_CFLAGS@
+-libstarparse_la_LDFLAGS += @GUILE_LDFLAGS@ -lpthread
++libstarparse_la_CFLAGS = @GUILE_CFLAGS@
++libstarparse_la_LIBADD = @GUILE_LIBS@ -lpthread
+ endif
+
+
+--- configure.ac
++++ configure.ac
+@@ -10,18 +10,13 @@
+
+ AM_INIT_AUTOMAKE
+
+-AC_ARG_ENABLE(guile,
++AC_ARG_ENABLE([guile],
+ AS_HELP_STRING([--enable-guile],
+- [build bindings for guile scheme interpreter]),
+- USE_GUILE=$enable_guile,
+- USE_GUILE=yes) # default value
+-
+-if test "x$USE_GUILE" = "xyes";
+-then
+- GUILE_FLAGS
+-fi
+-
+-AM_CONDITIONAL(ENABLE_GUILE, test "x$USE_GUILE" = "xyes")
++ [build bindings for guile scheme interpreter]))
++AS_IF([test "x$enable_guile" = "xyes"], [
++ PKG_CHECK_MODULES([GUILE], [guile-1.8])
++])
++AM_CONDITIONAL(ENABLE_GUILE, test "x$enable_guile" = "xyes")
+
+ AC_CONFIG_FILES([Makefile
+ starparse-env