summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-25 20:50:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-25 20:59:13 +0100
commit5d6e71977cacf505f87e1da254798423a6a5945f (patch)
tree2515c154b1720a4307bbb09a70cb8d7eb24cb38c /sci-libs/stellarsolver
parentsci-libs/stellarsolver: 2.2 version bump (diff)
downloadgentoo-5d6e71977cacf505f87e1da254798423a6a5945f.tar.gz
gentoo-5d6e71977cacf505f87e1da254798423a6a5945f.tar.bz2
gentoo-5d6e71977cacf505f87e1da254798423a6a5945f.zip
sci-libs/stellarsolver: Fix vasprintf implicit declaration warning
Upstream commit acb58bd78388adec25eb6e09ce6434546de008b8 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/stellarsolver')
-rw-r--r--sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch88
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.2.ebuild3
2 files changed, 91 insertions, 0 deletions
diff --git a/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
new file mode 100644
index 000000000000..b2625fe4429e
--- /dev/null
+++ b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
@@ -0,0 +1,88 @@
+From acb58bd78388adec25eb6e09ce6434546de008b8 Mon Sep 17 00:00:00 2001
+From: Robert Lancaster <rlancaste@gmail.com>
+Date: Wed, 16 Mar 2022 18:15:21 -0400
+Subject: [PATCH] Trying to eliminate vasprintf implicit declaration warning on
+ Linux
+
+---
+ stellarsolver/astrometry/util/bl.c | 4 +++-
+ stellarsolver/astrometry/util/errors.c | 4 +++-
+ stellarsolver/astrometry/util/fitsioutils.c | 3 +++
+ stellarsolver/astrometry/util/ioutils.c | 4 +++-
+ stellarsolver/astrometry/util/log.c | 4 +++-
+ 5 files changed, 15 insertions(+), 4 deletions(-)
+
+diff --git a/stellarsolver/astrometry/util/bl.c b/stellarsolver/astrometry/util/bl.c
+index 1a0fee9..e84d74a 100644
+--- a/stellarsolver/astrometry/util/bl.c
++++ b/stellarsolver/astrometry/util/bl.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/stellarsolver/astrometry/util/errors.c b/stellarsolver/astrometry/util/errors.c
+index 94f5f9c..b7c4e9f 100644
+--- a/stellarsolver/astrometry/util/errors.c
++++ b/stellarsolver/astrometry/util/errors.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+diff --git a/stellarsolver/astrometry/util/fitsioutils.c b/stellarsolver/astrometry/util/fitsioutils.c
+index 7451c36..f2b20bc 100644
+--- a/stellarsolver/astrometry/util/fitsioutils.c
++++ b/stellarsolver/astrometry/util/fitsioutils.c
+@@ -2,6 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdint.h>
+diff --git a/stellarsolver/astrometry/util/ioutils.c b/stellarsolver/astrometry/util/ioutils.c
+index ee17011..c490fb8 100644
+--- a/stellarsolver/astrometry/util/ioutils.c
++++ b/stellarsolver/astrometry/util/ioutils.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+diff --git a/stellarsolver/astrometry/util/log.c b/stellarsolver/astrometry/util/log.c
+index 256d5a1..1a2b8db 100644
+--- a/stellarsolver/astrometry/util/log.c
++++ b/stellarsolver/astrometry/util/log.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
diff --git a/sci-libs/stellarsolver/stellarsolver-2.2.ebuild b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
index 9a2aed549e42..3fd2a5f94878 100644
--- a/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
+++ b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
@@ -25,3 +25,6 @@ RDEPEND="
sci-astronomy/wcslib:=
"
DEPEND="${RDEPEND}"
+
+# https://github.com/rlancaste/stellarsolver/issues/108
+PATCHES=( "${FILESDIR}/${P}-fix-implicit-vasprintf-decl.patch" )