summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 20:36:35 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:42 -0500
commit5a44063457f2ff8711d1b96fba5e92852620750e (patch)
tree72c64f18ffcfc2770407ed93fd1b49a4d3165594 /sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
parentnet-fs/samba: Bump to version 4.12.0_rc4 (diff)
downloadgentoo-5a44063457f2ff8711d1b96fba5e92852620750e.tar.gz
gentoo-5a44063457f2ff8711d1b96fba5e92852620750e.tar.bz2
gentoo-5a44063457f2ff8711d1b96fba5e92852620750e.zip
sci-libs/suitesparseconfig: new version 5.4.0.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild')
-rw-r--r--sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
new file mode 100644
index 000000000000..6e48d59fa270
--- /dev/null
+++ b/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+# Upstream says, "no licensing restrictions apply to this file or to the
+# SuiteSparse_config directory".
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}