summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-06 21:11:43 +0000
committerSam James <sam@gentoo.org>2020-11-06 21:17:53 +0000
commit1414edd35cc4a15e8db0612267f5fbc3b9a810f2 (patch)
treea3c510d694d827cc1b3ec5d302c3f7f4c0461f2f /sci-libs/superlu/superlu-5.2.2.ebuild
parentnet-dialup/freeradius: Support alternate log path in initscript (diff)
downloadgentoo-1414edd35cc4a15e8db0612267f5fbc3b9a810f2.tar.gz
gentoo-1414edd35cc4a15e8db0612267f5fbc3b9a810f2.tar.bz2
gentoo-1414edd35cc4a15e8db0612267f5fbc3b9a810f2.zip
sci-libs/superlu: bump to 5.2.2
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/superlu/superlu-5.2.2.ebuild')
-rw-r--r--sci-libs/superlu/superlu-5.2.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/superlu/superlu-5.2.2.ebuild b/sci-libs/superlu/superlu-5.2.2.ebuild
new file mode 100644
index 000000000000..723d6ba29bbc
--- /dev/null
+++ b/sci-libs/superlu/superlu-5.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_STANDARD=77
+
+inherit cmake fortran-2
+
+DESCRIPTION="Sparse LU factorization library"
+HOMEPAGE="https://crd-legacy.lbl.gov/~xiaoye/SuperLU/"
+SRC_URI="https://crd-legacy.lbl.gov/~xiaoye/SuperLU//${PN}_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig
+ test? ( app-shells/tcsh )"
+RDEPEND="virtual/blas"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.2.2-no-internal-blas.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ # respect user's CFLAGS
+ sed -i -e 's/O3//' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_INCLUDEDIR="include/superlu"
+ -DBUILD_SHARED_LIBS=ON
+ -Denable_internal_blaslib=OFF
+ -Denable_tests=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r DOC/html
+ if use examples; then
+ docinto examples
+ dodoc -r EXAMPLE FORTRAN
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}