summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 18:43:07 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-03 17:33:04 +0000
commita54d848892e3cc60c4a172ceefdd15da614e54d8 (patch)
treefd59fe55c53b79401850a671949e2717dacf748f /sci-libs/symengine
parentsci-libs/scikits_learn: keep funcsigs and joblib bundled to avoid hair pulling (diff)
downloadgentoo-a54d848892e3cc60c4a172ceefdd15da614e54d8.tar.gz
gentoo-a54d848892e3cc60c4a172ceefdd15da614e54d8.tar.bz2
gentoo-a54d848892e3cc60c4a172ceefdd15da614e54d8.zip
sci-libs/symengine: fix for cxxflags C++11
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-libs/symengine')
-rw-r--r--sci-libs/symengine/symengine-0.3.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sci-libs/symengine/symengine-0.3.0.ebuild b/sci-libs/symengine/symengine-0.3.0.ebuild
index 5e0894d0d97a..45298fd2cbb7 100644
--- a/sci-libs/symengine/symengine-0.3.0.ebuild
+++ b/sci-libs/symengine/symengine-0.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="Fast symbolic manipulation library, written in C++"
HOMEPAGE="https://github.com/sympy/symengine"
@@ -67,5 +67,6 @@ src_configure() {
-DWITH_PTHREAD="$(usex threads)"
-DWITH_TCMALLOC="$(usex tcmalloc)"
)
+ test-flag-CXX -std=c++11 && append-cxxflags -std=c++11
CMAKE_BUILD_TYPE=Release cmake-utils_src_configure
}