summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/szip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/szip')
-rw-r--r--sci-libs/szip/Manifest1
-rw-r--r--sci-libs/szip/metadata.xml14
-rw-r--r--sci-libs/szip/szip-2.1-r1.ebuild20
-rw-r--r--sci-libs/szip/szip-2.1.ebuild24
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/szip/Manifest b/sci-libs/szip/Manifest
new file mode 100644
index 000000000000..2fce8df4e79d
--- /dev/null
+++ b/sci-libs/szip/Manifest
@@ -0,0 +1 @@
+DIST szip-2.1.tar.gz 383219 SHA256 9c03d79597f4c25a4a5fc10dbe912e4112394f805f8d9af52fc5c9fe15dbbdc7
diff --git a/sci-libs/szip/metadata.xml b/sci-libs/szip/metadata.xml
new file mode 100644
index 000000000000..a1d93197140d
--- /dev/null
+++ b/sci-libs/szip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Consultative Committee on Space Data Systems (CCSDS) has adopted
+ the extended-Rice algorithm for international standards for space
+ applications. Szip is reported to provide fast and effective
+ compression, specifically for the EOS data generated by the NASA
+ Earth Observatory System (EOS). It was originally developed at
+ University of New Mexico (UNM) and integrated with HDF4 by UNM
+ researchers and developers. It can be used for HDF 5 as well.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/szip/szip-2.1-r1.ebuild b/sci-libs/szip/szip-2.1-r1.ebuild
new file mode 100644
index 000000000000..3141afd70686
--- /dev/null
+++ b/sci-libs/szip/szip-2.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="Extended-Rice lossless compression algorithm implementation"
+HOMEPAGE="http://www.hdfgroup.org/doc_resource/SZIP/"
+SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
+LICENSE="szip"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="static-libs"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS=( RELEASE.txt HISTORY.txt examples/example.c )
diff --git a/sci-libs/szip/szip-2.1.ebuild b/sci-libs/szip/szip-2.1.ebuild
new file mode 100644
index 000000000000..465dcbd944c6
--- /dev/null
+++ b/sci-libs/szip/szip-2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Implementation of the extended-Rice lossless compression algorithm"
+HOMEPAGE="http://www.hdfgroup.org/doc_resource/SZIP/"
+SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
+LICENSE="szip"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+
+IUSE=""
+DEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc RELEASE.txt HISTORY.txt
+ insinto /usr/share/doc/${PF}/
+ emake -C examples clean || die
+ doins -r examples
+}