summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/ta-lib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/ta-lib/files')
-rw-r--r--sci-libs/ta-lib/files/ta-lib-0.4.0-asneeded.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/sci-libs/ta-lib/files/ta-lib-0.4.0-asneeded.patch b/sci-libs/ta-lib/files/ta-lib-0.4.0-asneeded.patch
new file mode 100644
index 000000000000..10183938e667
--- /dev/null
+++ b/sci-libs/ta-lib/files/ta-lib-0.4.0-asneeded.patch
@@ -0,0 +1,83 @@
+ src/Makefile.am | 2 +-
+ src/Makefile.in | 2 +-
+ src/ta_abstract/Makefile.am | 8 ++++----
+ src/ta_common/Makefile.am | 6 +++---
+ src/ta_func/Makefile.am | 6 +++---
+ 5 files changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 12bc5b6..b1a0c6b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,7 +8,7 @@ libta_lib_la_SOURCES =
+ libta_lib_la_LIBADD = \
+ ta_abstract/libta_abstract.la \
+ ta_func/libta_func.la \
+- ta_common/libta_common.la
++ ta_common/libta_common.la -lm
+
+ libta_lib_la_LDFLAGS = -version-info $(TALIB_LIBRARY_VERSION)
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 489b44a..ef1f506 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -56,7 +56,7 @@ am_libta_lib_la_OBJECTS =
+ libta_lib_la_OBJECTS = $(am_libta_lib_la_OBJECTS)
+ libta_lib_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(libta_lib_la_LDFLAGS) $(LDFLAGS) -o $@
++ $(libta_lib_la_LDFLAGS) $(LDFLAGS) -lm -o $@
+ DEFAULT_INCLUDES = -I. -I$(top_builddir)/include@am__isrc@
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+diff --git a/src/ta_abstract/Makefile.am b/src/ta_abstract/Makefile.am
+index cba69bb..4411234 100644
+--- a/src/ta_abstract/Makefile.am
++++ b/src/ta_abstract/Makefile.am
+@@ -38,12 +38,12 @@ libta_abstract_gc_la_SOURCES = $(libta_abstract_la_SOURCES)
+ libta_abstract_la_LDFLAGS = -version-info $(TALIB_LIBRARY_VERSION)
+ libta_abstract_gc_la_LDFLAGS = $(libta_abstract_la_LDFLAGS)
+
+-libta_abstract_la_CPPFLAGS = -I../ta_common/ -Iframes/
++libta_abstract_la_CPPFLAGS = -I$(top_srcdir)/src/ta_common/ -Iframes/
+
+ # The 'gc' version is a minimal version used to just to compile gen_code
+ libta_abstract_gc_la_CPPFLAGS = -DTA_GEN_CODE $(libta_abstract_la_CPPFLAGS)
+
+ libta_abstractdir=$(includedir)/ta-lib/
+-libta_abstract_HEADERS = ../../include/ta_defs.h \
+- ../../include/ta_libc.h \
+- ../../include/ta_abstract.h
++libta_abstract_HEADERS = $(top_srcdir)/include/ta_defs.h \
++ $(top_srcdir)/include/ta_libc.h \
++ $(top_srcdir)/include/ta_abstract.h
+diff --git a/src/ta_common/Makefile.am b/src/ta_common/Makefile.am
+index 9454490..3e59bd8 100644
+--- a/src/ta_common/Makefile.am
++++ b/src/ta_common/Makefile.am
+@@ -9,7 +9,7 @@ libta_common_la_SOURCES = ta_global.c \
+ libta_common_la_LDFLAGS = -version-info $(TALIB_LIBRARY_VERSION)
+
+ libta_commondir=$(includedir)/ta-lib/
+-libta_common_HEADERS = ../../include/ta_defs.h \
+- ../../include/ta_libc.h \
+- ../../include/ta_common.h
++libta_common_HEADERS = $(top_builddir)/include/ta_defs.h \
++ $(top_builddir)/include/ta_libc.h \
++ $(top_builddir)/include/ta_common.h
+
+diff --git a/src/ta_func/Makefile.am b/src/ta_func/Makefile.am
+index 030a516..299baf9 100644
+--- a/src/ta_func/Makefile.am
++++ b/src/ta_func/Makefile.am
+@@ -165,6 +165,6 @@ libta_func_la_SOURCES = ta_utility.c \
+ libta_func_la_LDFLAGS = -version-info $(TALIB_LIBRARY_VERSION)
+
+ libta_funcdir=$(includedir)/ta-lib/
+-libta_func_HEADERS = ../../include/ta_defs.h \
+- ../../include/ta_libc.h \
+- ../../include/ta_func.h
++libta_func_HEADERS = $(top_builddir)/include/ta_defs.h \
++ $(top_builddir)/include/ta_libc.h \
++ $(top_builddir)/include/ta_func.h