summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-08 18:28:56 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-09 01:25:23 +0800
commit600add5064f5b8be44d05c3fda59aba2ce5ef4ac (patch)
treed2c27fa307fa591123ed57b777d4740654b914d0 /sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild
parentkde-frameworks/purpose: Drop 5.64.0-r1 (diff)
downloadgentoo-600add5064f5b8be44d05c3fda59aba2ce5ef4ac.tar.gz
gentoo-600add5064f5b8be44d05c3fda59aba2ce5ef4ac.tar.bz2
gentoo-600add5064f5b8be44d05c3fda59aba2ce5ef4ac.zip
sci-libs/tensorflow-estimator: bump 1.15.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild')
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild
new file mode 100644
index 000000000000..7913f44ba2cf
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-1.15.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_prepare() {
+ sed -i "/^_VERSION/s/'[0-9.]*'/'${PV}'/" tensorflow_estimator/tools/pip_package/setup.py || die
+ bazel_setup_bazelrc
+ default
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}