summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-06-08 12:51:48 +0800
committerJason Zaman <perfinion@gentoo.org>2020-06-08 12:55:30 +0800
commit4f0a1a643c32e762f1cf8f07cc14da184788080d (patch)
tree4819521a9bd99c0a3cf4cf1f4cf8d9c6f69a8460 /sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild
parenteclass: last-rite php-ext-source-r2.eclass (diff)
downloadgentoo-4f0a1a643c32e762f1cf8f07cc14da184788080d.tar.gz
gentoo-4f0a1a643c32e762f1cf8f07cc14da184788080d.tar.bz2
gentoo-4f0a1a643c32e762f1cf8f07cc14da184788080d.zip
sci-libs/tensorflow-estimator: fix compile error
The bazel build step used the incorrect python, so duplicate the sources and build multiple times Closes: https://bugs.gentoo.org/725856 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild')
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..20a13ee1c5ad
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.2.0-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip -> bazelbuild-rules_cc-0d5f3f2768c6ca2faca0079a997a97ce22997a0c.zip
+ https://github.com/bazelbuild/rules_cc/archive/8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip -> bazelbuild-rules_cc-8bd6cd75d03c01bb82561a96d9c1f9f7157b13d0.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-java/java-config"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+
+ do_compile() {
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+ }
+
+ python_foreach_impl run_in_build_dir do_compile
+}
+
+src_install() {
+ do_install() {
+ cd "${T}/src-${EPYTHON/./_}" || die
+ esetup.py install
+ python_optimize
+ }
+ python_foreach_impl do_install
+
+ cd "${S}" || die
+ einstalldocs
+}