summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2020-03-30 07:51:42 +0800
committerJason Zaman <perfinion@gentoo.org>2020-04-07 11:04:48 +0800
commitf10f76acf38ba9c7df5d6437aa8ad93732aad977 (patch)
tree35e04f4d90191faccde4556d94a9f1d8c7ae4c2d /sci-libs/tensorflow
parentsci-libs/adolc: drop old (diff)
downloadgentoo-f10f76acf38ba9c7df5d6437aa8ad93732aad977.tar.gz
gentoo-f10f76acf38ba9c7df5d6437aa8ad93732aad977.tar.bz2
gentoo-f10f76acf38ba9c7df5d6437aa8ad93732aad977.zip
sci-libs/tensorflow: replace python_export with python_get_sitedir
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow')
-rw-r--r--sci-libs/tensorflow/tensorflow-1.15.0.ebuild8
-rw-r--r--sci-libs/tensorflow/tensorflow-2.0.0.ebuild8
-rw-r--r--sci-libs/tensorflow/tensorflow-2.1.0.ebuild8
-rw-r--r--sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild8
4 files changed, 12 insertions, 20 deletions
diff --git a/sci-libs/tensorflow/tensorflow-1.15.0.ebuild b/sci-libs/tensorflow/tensorflow-1.15.0.ebuild
index 7844e3a1a28b..8190ff5d464a 100644
--- a/sci-libs/tensorflow/tensorflow-1.15.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-1.15.0.ebuild
@@ -189,9 +189,8 @@ src_configure() {
export TF_SET_ANDROID_WORKSPACE=0
if use python; then
- python_export PYTHON_SITEDIR
export PYTHON_BIN_PATH="${PYTHON}"
- export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+ export PYTHON_LIB_PATH="$(python_get_sitedir)"
else
export PYTHON_BIN_PATH="$(which python)"
export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -320,9 +319,8 @@ src_install() {
esetup.py install
# libtensorflow_framework.so is in /usr/lib already
- python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
python_optimize
}
diff --git a/sci-libs/tensorflow/tensorflow-2.0.0.ebuild b/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
index 902eac64ba84..4e04d4e51c6d 100644
--- a/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.0.0.ebuild
@@ -188,9 +188,8 @@ src_configure() {
export TF_SET_ANDROID_WORKSPACE=0
if use python; then
- python_export PYTHON_SITEDIR
export PYTHON_BIN_PATH="${PYTHON}"
- export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+ export PYTHON_LIB_PATH="$(python_get_sitedir)"
else
export PYTHON_BIN_PATH="$(which python)"
export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -319,9 +318,8 @@ src_install() {
esetup.py install
# libtensorflow_framework.so is in /usr/lib already
- python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
python_optimize
}
diff --git a/sci-libs/tensorflow/tensorflow-2.1.0.ebuild b/sci-libs/tensorflow/tensorflow-2.1.0.ebuild
index ff79ebeaaeb4..4f7b9c8ecf7d 100644
--- a/sci-libs/tensorflow/tensorflow-2.1.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.1.0.ebuild
@@ -194,9 +194,8 @@ src_configure() {
export TF_SET_ANDROID_WORKSPACE=0
if use python; then
- python_export PYTHON_SITEDIR
export PYTHON_BIN_PATH="${PYTHON}"
- export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+ export PYTHON_LIB_PATH="$(python_get_sitedir)"
else
export PYTHON_BIN_PATH="$(which python)"
export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -326,9 +325,8 @@ src_install() {
esetup.py install
# libtensorflow_framework.so is in /usr/lib already
- python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
python_optimize
}
diff --git a/sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild b/sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild
index 019244a3ce2a..c0ab709f7b9d 100644
--- a/sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild
+++ b/sci-libs/tensorflow/tensorflow-2.2.0_rc2.ebuild
@@ -196,9 +196,8 @@ src_configure() {
export TF_SET_ANDROID_WORKSPACE=0
if use python; then
- python_export PYTHON_SITEDIR
export PYTHON_BIN_PATH="${PYTHON}"
- export PYTHON_LIB_PATH="${PYTHON_SITEDIR}"
+ export PYTHON_LIB_PATH="$(python_get_sitedir)"
else
export PYTHON_BIN_PATH="$(which python)"
export PYTHON_LIB_PATH="$(python -c 'from distutils.sysconfig import *; print(get_python_lib())')"
@@ -327,9 +326,8 @@ src_install() {
esetup.py install
# libtensorflow_framework.so is in /usr/lib already
- python_export PYTHON_SITEDIR PYTHON_SCRIPTDIR
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}/lib${PN}_framework.so* || die
- rm -f "${D}/${PYTHON_SITEDIR}"/${PN}_core/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}/lib${PN}_framework.so* || die
+ rm -f "${D}/$(python_get_sitedir)"/${PN}_core/lib${PN}_framework.so* || die
python_optimize
}