summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-07-06 23:36:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-07-06 23:37:16 +1000
commit491a9cab41c19581749635d563ca2cbe1c138726 (patch)
tree631d1c641464dfe8c5e676a456527661c650ad6c /sci-libs/vtk/files
parentdev-vcs/subversion: Bump to version 1.9.6 (diff)
downloadgentoo-491a9cab41c19581749635d563ca2cbe1c138726.tar.gz
gentoo-491a9cab41c19581749635d563ca2cbe1c138726.tar.bz2
gentoo-491a9cab41c19581749635d563ca2cbe1c138726.zip
Revert "sci-libs/vtk: remove old"
This broke the tree. This reverts commit b7f85bc606ce1067c6cd9d607c4e07ea55c2f9bf.
Diffstat (limited to 'sci-libs/vtk/files')
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-freetype.patch22
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-gcc67.patch26
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-gdal2.patch33
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-glext.patch13
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-install.patch19
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-netcdf.patch29
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-system.patch27
-rw-r--r--sci-libs/vtk/files/vtk-6.1.0-web.patch25
8 files changed, 194 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-6.1.0-freetype.patch b/sci-libs/vtk/files/vtk-6.1.0-freetype.patch
new file mode 100644
index 000000000000..b7d3e409cde1
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-freetype.patch
@@ -0,0 +1,22 @@
+--- a/ParaView-v4.2.0-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx_orig 2014-12-23 09:25:35.000000000 +0100
++++ b/ParaView-v4.2.0-source/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2014-12-24 09:40:31.886953389 +0100
+@@ -1185,7 +1185,7 @@
+ if (bitmap)
+ {
+ metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++ metaData.descent = std::min(-(static_cast<int>(bitmap->rows) - (bitmapGlyph->top - 1)),
+ metaData.descent);
+ }
+ ++heightString;
+@@ -1952,8 +1952,8 @@
+ if (bitmap)
+ {
+ bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++ bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + static_cast<int>(bitmap->width));
++ bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - static_cast<int>(bitmap->rows));
+ bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+ }
+ else
diff --git a/sci-libs/vtk/files/vtk-6.1.0-gcc67.patch b/sci-libs/vtk/files/vtk-6.1.0-gcc67.patch
new file mode 100644
index 000000000000..83d1ae18f213
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-gcc67.patch
@@ -0,0 +1,26 @@
+diff --git a/old/vtkCompilerExtras.cmake b/CMake/vtkCompilerExtras.cmake
+index 05b2db9..92c2c4c 100644
+--- a/old/vtkCompilerExtras.cmake
++++ b/CMake/vtkCompilerExtras.cmake
+@@ -27,7 +27,7 @@ if(CMAKE_COMPILER_IS_GNUCXX)
+ OUTPUT_VARIABLE _gcc_version_info
+ ERROR_VARIABLE _gcc_version_info)
+
+- string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]"
++ string (REGEX MATCH "[0-9]\\.[0-9]\\.[0-9]"
+ _gcc_version "${_gcc_version_info}")
+ if(NOT _gcc_version)
+ string (REGEX REPLACE ".*\\(GCC\\).* ([34]\\.[0-9]) .*" "\\1.0"
+diff --git a/old/GenerateExportHeader.cmake b/CMake/GenerateExportHeader.cmake
+index 3cc12dd..b7a47df 100644
+--- a/old/GenerateExportHeader.cmake
++++ b/CMake/GenerateExportHeader.cmake
+@@ -166,7 +166,7 @@ macro(_test_compiler_hidden_visibility)
+ execute_process(COMMAND ${CMAKE_C_COMPILER} --version
+ OUTPUT_VARIABLE _gcc_version_info
+ ERROR_VARIABLE _gcc_version_info)
+- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]"
++ string(REGEX MATCH "[0-9]\\.[0-9]\\.[0-9]"
+ _gcc_version "${_gcc_version_info}")
+ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
+ # patch level, handle this here:
diff --git a/sci-libs/vtk/files/vtk-6.1.0-gdal2.patch b/sci-libs/vtk/files/vtk-6.1.0-gdal2.patch
new file mode 100644
index 000000000000..c21864102278
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-gdal2.patch
@@ -0,0 +1,33 @@
+diff --git a/IO/GDAL/vtkGDALVectorReader.cxx b/IO/GDAL/vtkGDALVectorReader.cxx
+index 86854a0..a0e234a 100644
+--- a/IO/GDAL/vtkGDALVectorReader.cxx
++++ b/IO/GDAL/vtkGDALVectorReader.cxx
+# Patch to build against newer GDAL per upstream commit
+# https://projects.archlinux.org/svntogit/community.git/tree/trunk/gdal2.patch?h=packages/vtk&id=43307598a98872fd4ce7739e47f5bb4cfcb5372d
+@@ -44,7 +44,7 @@ class vtkGDALVectorReader::Internal
+ public:
+ Internal( const char* srcName, int srcMode, int appendFeatures, int addFeatIds )
+ {
+- this->Source = OGRSFDriverRegistrar::Open( srcName, srcMode, &this->Driver );
++ this->Source = (GDALDataset*) OGROpen( srcName, srcMode, NULL );
+ if ( ! this->Source )
+ {
+ this->LastError = CPLGetLastErrorMsg();
+@@ -61,7 +61,7 @@ public:
+ {
+ if ( this->Source )
+ {
+- OGRDataSource::DestroyDataSource( this->Source );
++ GDALClose( (GDALDatasetH) this->Source );
+ }
+ }
+
+@@ -304,7 +304,7 @@ public:
+ return nCells;
+ }
+
+- OGRDataSource* Source;
++ GDALDataset* Source;
+ OGRSFDriver* Driver;
+ const char* LastError;
+ int LayerIdx;
diff --git a/sci-libs/vtk/files/vtk-6.1.0-glext.patch b/sci-libs/vtk/files/vtk-6.1.0-glext.patch
new file mode 100644
index 000000000000..b5529a5fc3d5
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-glext.patch
@@ -0,0 +1,13 @@
+diff -up VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h.glext VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h
+--- VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h.glext 2014-01-22 08:55:41.000000000 -0700
++++ VTK-6.1.0/Rendering/OpenGL/vtkOpenGL.h 2014-11-19 10:27:12.349345199 -0700
+@@ -19,7 +19,8 @@
+ #include "vtkConfigure.h"
+
+ // To prevent gl.h to include glext.h provided by the system
+-#define GL_GLEXT_LEGACY
++// https://bugzilla.redhat.com/show_bug.cgi?id=1138466
++// #define GL_GLEXT_LEGACY
+ #if defined(__APPLE__) && (defined(VTK_USE_CARBON) || defined(VTK_USE_COCOA))
+ # include <OpenGL/gl.h> // Include OpenGL API.
+ #else
diff --git a/sci-libs/vtk/files/vtk-6.1.0-install.patch b/sci-libs/vtk/files/vtk-6.1.0-install.patch
new file mode 100644
index 000000000000..27c6c3adfee9
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-install.patch
@@ -0,0 +1,19 @@
+diff -up VTK-6.1.0/CMake/vtkModuleTop.cmake.install VTK-6.1.0/CMake/vtkModuleTop.cmake
+--- VTK-6.1.0/CMake/vtkModuleTop.cmake.install 2014-01-23 19:12:04.922871103 -0700
++++ VTK-6.1.0/CMake/vtkModuleTop.cmake 2014-01-23 19:14:33.002645155 -0700
+@@ -330,11 +330,15 @@ if (NOT VTK_INSTALL_NO_DEVELOPMENT)
+ CMake/pythonmodules.h.in
+ CMake/UseVTK.cmake
+ CMake/FindTCL.cmake
++ CMake/TopologicalSort.cmake
+ CMake/vtkTclTkMacros.cmake
+ CMake/vtk-forward.c.in
++ CMake/vtkGroups.cmake
+ CMake/vtkForwardingExecutable.cmake
+ CMake/vtkJavaWrapping.cmake
+ CMake/vtkMakeInstantiator.cmake
++ CMake/vtkMakeInstantiator.cxx.in
++ CMake/vtkMakeInstantiator.h.in
+ CMake/vtkModuleAPI.cmake
+ CMake/vtkModuleHeaders.cmake.in
+ CMake/vtkModuleInfo.cmake.in
diff --git a/sci-libs/vtk/files/vtk-6.1.0-netcdf.patch b/sci-libs/vtk/files/vtk-6.1.0-netcdf.patch
new file mode 100644
index 000000000000..e6f8b6431720
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-netcdf.patch
@@ -0,0 +1,29 @@
+diff -up VTK/ThirdParty/netcdf/CMakeLists.txt.netcdf VTK/ThirdParty/netcdf/CMakeLists.txt
+--- VTK/ThirdParty/netcdf/CMakeLists.txt.netcdf 2013-12-27 20:29:11.644289659 -0700
++++ VTK/ThirdParty/netcdf/CMakeLists.txt 2013-12-27 20:33:48.071895769 -0700
+@@ -1,10 +1,18 @@
+-vtk_module_third_party(NetCDF
+- LIBRARIES vtkNetCDF vtkNetCDF_cxx
+- INCLUDE_DIRS
+- ${CMAKE_CURRENT_SOURCE_DIR}/vtknetcdf/include
+- ${CMAKE_CURRENT_BINARY_DIR}/vtknetcdf
+- COMPONENTS C CXX
+- )
++if(NOT VTK_USE_SYSTEM_NETCDF)
++ vtk_module_third_party(NetCDF
++ LIBRARIES vtkNetCDF vtkNetCDF_cxx
++ INCLUDE_DIRS
++ ${CMAKE_CURRENT_SOURCE_DIR}/vtknetcdf/include
++ ${CMAKE_CURRENT_BINARY_DIR}/vtknetcdf
++ COMPONENTS C CXX
++ )
++else(NOT VTK_USE_SYSTEM_NETCDF)
++ vtk_module_third_party(NetCDF
++ LIBRARIES vtkNetCDF netcdf
++ COMPONENTS C CXX
++ )
++endif()
++
+
+ #Configure the top cpp header to switch between system and internal
+ #netcdf just like vtk_module_third_party does for the c header.
diff --git a/sci-libs/vtk/files/vtk-6.1.0-system.patch b/sci-libs/vtk/files/vtk-6.1.0-system.patch
new file mode 100644
index 000000000000..c75d544447ea
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-system.patch
@@ -0,0 +1,27 @@
+diff -up VTK/CMake/vtkModuleMacros.cmake.system VTK/CMake/vtkModuleMacros.cmake
+--- VTK/CMake/vtkModuleMacros.cmake.system 2013-12-24 19:17:43.000000000 -0700
++++ VTK/CMake/vtkModuleMacros.cmake 2013-12-27 20:28:22.375573277 -0700
+@@ -682,7 +682,7 @@ macro(vtk_module_third_party _pkg)
+ message(FATAL_ERROR "Cannot specify both LIBRARIES and NO_LIBRARIES")
+ endif()
+
+- option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" OFF)
++ option(VTK_USE_SYSTEM_${_upper} "Use system-installed ${_pkg}" ${VTK_USE_SYSTEM_LIBRARIES})
+ mark_as_advanced(VTK_USE_SYSTEM_${_upper})
+
+ if(VTK_USE_SYSTEM_${_upper})
+diff -up VTK/CMakeLists.txt.system VTK/CMakeLists.txt
+--- VTK/CMakeLists.txt.system 2013-12-27 20:28:22.374573241 -0700
++++ VTK/CMakeLists.txt 2013-12-27 20:28:48.118669708 -0700
+@@ -132,6 +132,11 @@ if (CMAKE_CROSSCOMPILING AND NOT COMPILE
+ endif()
+
+ #-----------------------------------------------------------------------------
++# Do we try to use system libraries by default?
++OPTION(VTK_USE_SYSTEM_LIBRARIES "Use the system's libraries by default." OFF)
++MARK_AS_ADVANCED(VTK_USE_SYSTEM_LIBRARIES)
++
++#-----------------------------------------------------------------------------
+ # The third party macros are still used in one or two third party builds.
+ include(vtkThirdParty)
+
diff --git a/sci-libs/vtk/files/vtk-6.1.0-web.patch b/sci-libs/vtk/files/vtk-6.1.0-web.patch
new file mode 100644
index 000000000000..a85f2cd99640
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.1.0-web.patch
@@ -0,0 +1,25 @@
+From 58373b120db6d51c6d5eace38447cdb45ff858d1 Mon Sep 17 00:00:00 2001
+From: Patric Schmitz <patric.schmitz@rwth-aachen.de>
+Date: Tue, 28 Oct 2014 16:24:22 +0100
+Subject: [PATCH] Include vtkPythonPackages in Web/JavaScript/CMakeLists.txt
+
+Change-Id: Ie7bffa19bdaa78c5b090c886e50c1af76e2aadee
+---
+ Web/Applications/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Web/Applications/CMakeLists.txt b/Web/Applications/CMakeLists.txt
+index c9e7ad3..b4c9a60 100644
+--- a/Web/Applications/CMakeLists.txt
++++ b/Web/Applications/CMakeLists.txt
+@@ -12,6 +12,7 @@ set(WEB_APPLICATIONS
+
+ set(WEB_APPS_DEPENDS)
+
++include(vtkPythonPackages) # for copy_files_recursive
+ foreach(_app ${WEB_APPLICATIONS})
+ file(MAKE_DIRECTORY "${VTK_WWW_DIR}/apps/${_app}")
+
+--
+2.2.1
+