summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-05 00:58:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-05 02:39:24 +0200
commitd7a85e1f78219f0d5b2603f422d6e33297aaf68c (patch)
treee615a0810e19d264684b2b7ae2981c11ab399d74 /sci-libs/xdmf2
parentnet-libs/signond: Fix runtime crashes (diff)
downloadgentoo-d7a85e1f78219f0d5b2603f422d6e33297aaf68c.tar.gz
gentoo-d7a85e1f78219f0d5b2603f422d6e33297aaf68c.tar.bz2
gentoo-d7a85e1f78219f0d5b2603f422d6e33297aaf68c.zip
sci-libs/xdmf2: Drop eternally broken IUSE=python, EAPI-7 bump
- Switch to cmake.eclass - Drop ~arm keyword (no revdeps) - Drop obsolete c++14 flag Closes: https://bugs.gentoo.org/664920 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/xdmf2')
-rw-r--r--sci-libs/xdmf2/xdmf2-1.0_p141226-r4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/xdmf2/xdmf2-1.0_p141226-r4.ebuild b/sci-libs/xdmf2/xdmf2-1.0_p141226-r4.ebuild
new file mode 100644
index 000000000000..e196d6f8dd2b
--- /dev/null
+++ b/sci-libs/xdmf2/xdmf2-1.0_p141226-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="eXtensible Data Model and Format"
+HOMEPAGE="http://xdmf.org/index.php/Main_Page"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="VTK"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ sci-libs/hdf5:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-module.patch
+ "${FILESDIR}"/${P}-cannot-find-hdf5-bug-591302.patch
+ "${FILESDIR}"/${P}-cmake-3.12.patch
+)
+
+src_prepare() {
+ sed \
+ -e "/DESTINATION/s:lib:$(get_libdir):g" \
+ -e "/INSTALL/s:lib:$(get_libdir):g" \
+ -i CMakeLists.txt core/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=1
+ -DXDMF_BUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_TESTING=$(usex test)
+ -DXDMF_WRAP_PYTHON=OFF
+ -DXDMF_WRAP_JAVA=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dosym XdmfConfig.cmake /usr/share/cmake/Modules/${PN}Config.cmake
+}