summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/xkaapi/xkaapi-2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/xkaapi/xkaapi-2.1.ebuild')
-rw-r--r--sci-libs/xkaapi/xkaapi-2.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/xkaapi/xkaapi-2.1.ebuild b/sci-libs/xkaapi/xkaapi-2.1.ebuild
new file mode 100644
index 000000000000..bebd02623457
--- /dev/null
+++ b/sci-libs/xkaapi/xkaapi-2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
+
+UPSTREAM_NO=32735
+
+DESCRIPTION="Kernel for Adaptative, Asynchronous Parallel and Interactive programming"
+HOMEPAGE="http://kaapi.gforge.inria.fr"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${UPSTREAM_NO}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas cxx fortran gpu openmp static-libs"
+
+RDEPEND="
+ sys-apps/hwloc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-ffi.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:-Werror::g' \
+ -i tests/testsuite* tests/*/*.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-mode=gentoo
+ --enable-api-kaapic
+ --enable-api-quark
+ --with-ccache=no
+ --enable-hwloc
+ --with-libffi="${EPREFIX}"/usr
+ --enable-target$(usex gpu gpu mt)
+ $(use_enable fortran api-kaapif)
+ $(use_enable cxx api-kaapixx)
+ $(use_enable blas kblas)
+ $(use_enable openmp libkomp)
+# $(use_with plasma "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}