summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-04 09:41:54 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-04 10:04:03 -0400
commit030d616e0dbb91f18a34fdb6c5cb72024b33915f (patch)
treeef182c00993c13ecaaeeede12db8394c2e8aa5a3 /sci-libs
parentsys-devel/gcc: ada USE flag description (diff)
downloadgentoo-030d616e0dbb91f18a34fdb6c5cb72024b33915f.tar.gz
gentoo-030d616e0dbb91f18a34fdb6c5cb72024b33915f.tar.bz2
gentoo-030d616e0dbb91f18a34fdb6c5cb72024b33915f.zip
sci-libs/suitesparse: new version 5.4.0.
All of the individual suitesparse components have been updated, but I didn't realize there was a metapackage. And the 4.x versions of the metapackage have incorrect dependencies that are trying to pull in the components that belong to suitesparse-5.4.0. This is producing some confusing errors. This commit adds a new version of the metapackage with correct dependencies (tied to the versions of the components that ship with suitesparse-5.4.0), and should let ~arch users upgrade everything after switching from USE=metis to USE=partition. At some later point, we can prune the 4.x metapackage and components and be dont with that. Bug: https://bugs.gentoo.org/711610 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/suitesparse/metadata.xml19
-rw-r--r--sci-libs/suitesparse/suitesparse-5.4.0.ebuild27
2 files changed, 42 insertions, 4 deletions
diff --git a/sci-libs/suitesparse/metadata.xml b/sci-libs/suitesparse/metadata.xml
index a30fdd382ec1..d8c0d9a2971e 100644
--- a/sci-libs/suitesparse/metadata.xml
+++ b/sci-libs/suitesparse/metadata.xml
@@ -26,11 +26,22 @@
* RBio: MATLAB toolbox for reading/writing sparse matrices
* LINFACTOR: solve Ax=b using LU or CHOL
* MESHND: 2D and 3D mesh generation and nested dissection
- * SSMULT: sparse matrix times sparse matrix
+ * SSMULT: sparse matrix times sparse matrix
</longdescription>
<use>
- <flag name="cuda">Enable nvidia cuda toolkit for speeding up computations</flag>
- <flag name="metis">Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg></flag>
- <flag name="tbb">Enable multithreading with the Intel Threads Building Block <pkg>dev-cpp/tbb</pkg></flag>
+ <flag name="cuda">
+ Enable nvidia cuda toolkit for speeding up computations
+ </flag>
+ <flag name="metis">
+ Enable the Partition module to cholmod using <pkg>sci-libs/metis</pkg>
+ </flag>
+ <flag name="partition">
+ Enable graph partitioning and graph-partition-based orderings
+ through <pkg>sci-libs/metis</pkg> or <pkg>sci-libs/parmetis</pkg>
+ </flag>
+ <flag name="tbb">
+ Enable multithreading with the Intel Threads Building Block
+ <pkg>dev-cpp/tbb</pkg>
+ </flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/suitesparse/suitesparse-5.4.0.ebuild b/sci-libs/suitesparse/suitesparse-5.4.0.ebuild
new file mode 100644
index 000000000000..2098b0804964
--- /dev/null
+++ b/sci-libs/suitesparse/suitesparse-5.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Metapackage for a suite of sparse matrix tools"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+
+LICENSE="metapackage"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc lapack partition tbb"
+DEPEND=""
+RDEPEND="
+ ~sci-libs/suitesparseconfig-${PV}
+ ~sci-libs/amd-2.4.6[doc?]
+ ~sci-libs/btf-1.2.6
+ ~sci-libs/camd-2.4.6[doc?]
+ ~sci-libs/ccolamd-2.9.6
+ ~sci-libs/cholmod-3.0.13[cuda?,doc?,partition?,lapack?]
+ ~sci-libs/colamd-2.9.6
+ ~sci-libs/cxsparse-3.2.0
+ ~sci-libs/klu-1.3.9[doc?]
+ ~sci-libs/ldl-2.2.6[doc?]
+ ~sci-libs/spqr-2.0.9[doc?,partition?,tbb?]
+ ~sci-libs/umfpack-5.7.9[doc?,cholmod]"