summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-31 11:37:07 +0000
committerSam James <sam@gentoo.org>2021-05-31 11:38:01 +0000
commit0980511b01c8aeba0da6936228433088c33c7298 (patch)
treed2fb6ab9695c557e60417fa9cde344b53c528d6d /sci-libs
parentprofiles: unmask examples USE flag for vtk-9 (diff)
downloadgentoo-0980511b01c8aeba0da6936228433088c33c7298.tar.gz
gentoo-0980511b01c8aeba0da6936228433088c33c7298.tar.bz2
gentoo-0980511b01c8aeba0da6936228433088c33c7298.zip
sci-libs/vtk: add various GCC 11 fixes
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/files/vtk-9.0.1-limits-include-gcc11.patch84
-rw-r--r--sci-libs/vtk/vtk-9.0.1.ebuild1
2 files changed, 85 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-9.0.1-limits-include-gcc11.patch b/sci-libs/vtk/files/vtk-9.0.1-limits-include-gcc11.patch
new file mode 100644
index 000000000000..5473378512f9
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.0.1-limits-include-gcc11.patch
@@ -0,0 +1,84 @@
+From c7d6a8d81367a4ed92163c059aa3181386eabc24 Mon Sep 17 00:00:00 2001
+From: Ben Boeckel <ben.boeckel@kitware.com>
+Date: Mon, 3 May 2021 11:55:27 -0400
+Subject: [PATCH] vtkDataArrayPrivate: include <limits> for std::numeric_limits
+
+See: #18194
+---
+ Common/Core/vtkDataArrayPrivate.txx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Common/Core/vtkDataArrayPrivate.txx b/Common/Core/vtkDataArrayPrivate.txx
+index eb366f1c6d0..6709f7f3ac1 100644
+--- a/Common/Core/vtkDataArrayPrivate.txx
++++ b/Common/Core/vtkDataArrayPrivate.txx
+@@ -24,6 +24,7 @@
+ #include <algorithm>
+ #include <array>
+ #include <cassert> // for assert()
++#include <limits>
+ #include <vector>
+
+ namespace vtkDataArrayPrivate
+--
+GitLab
+diff --git a/Common/Core/vtkGenericDataArrayLookupHelper.h b/Common/Core/vtkGenericDataArrayLookupHelper.h
+index f278e27..de6d842 100644
+--- a/Common/Core/vtkGenericDataArrayLookupHelper.h
++++ b/Common/Core/vtkGenericDataArrayLookupHelper.h
+@@ -25,6 +25,7 @@
+ #include "vtkIdList.h"
+ #include <algorithm>
+ #include <cmath>
++#include <limits>
+ #include <unordered_map>
+ #include <vector>
+
+diff --git a/Common/DataModel/vtkPiecewiseFunction.cxx b/Common/DataModel/vtkPiecewiseFunction.cxx
+index c75935fd..9459ce90 100644
+--- a/Common/DataModel/vtkPiecewiseFunction.cxx
++++ b/Common/DataModel/vtkPiecewiseFunction.cxx
+@@ -22,6 +22,7 @@
+ #include <cassert>
+ #include <cmath>
+ #include <iterator>
++#include <limits>
+ #include <set>
+ #include <vector>
+
+diff --git a/Rendering/Core/vtkColorTransferFunction.cxx b/Rendering/Core/vtkColorTransferFunction.cxx
+index 40504e5..125597b 100644
+--- a/Rendering/Core/vtkColorTransferFunction.cxx
++++ b/Rendering/Core/vtkColorTransferFunction.cxx
+@@ -21,6 +21,7 @@
+ #include <algorithm>
+ #include <cmath>
+ #include <iterator>
++#include <limits>
+ #include <set>
+ #include <vector>
+
+diff --git a/Filters/HyperTree/vtkHyperTreeGridThreshold.cxx b/Filters/HyperTree/vtkHyperTreeGridThreshold.cxx
+index 9944db6..01a1517 100644
+--- a/Filters/HyperTree/vtkHyperTreeGridThreshold.cxx
++++ b/Filters/HyperTree/vtkHyperTreeGridThreshold.cxx
+@@ -28,6 +28,7 @@
+ #include "vtkHyperTreeGridNonOrientedCursor.h"
+
+ #include <cmath>
++#include <limits>
+
+ vtkStandardNewMacro(vtkHyperTreeGridThreshold);
+
+diff --git a/Common/DataModel/Testing/Cxx/UnitTestLine.cxx b/Common/DataModel/Testing/Cxx/UnitTestLine.cxx
+index 7823d61..02f627d 100644
+--- a/Common/DataModel/Testing/Cxx/UnitTestLine.cxx
++++ b/Common/DataModel/Testing/Cxx/UnitTestLine.cxx
+@@ -14,6 +14,7 @@
+ =========================================================================*/
+
+ #include <cmath>
++#include <limits>
+
+ #include "vtkLine.h"
+ #include "vtkMath.h"
diff --git a/sci-libs/vtk/vtk-9.0.1.ebuild b/sci-libs/vtk/vtk-9.0.1.ebuild
index bf7a3ba0a1b2..848e2fce63de 100644
--- a/sci-libs/vtk/vtk-9.0.1.ebuild
+++ b/sci-libs/vtk/vtk-9.0.1.ebuild
@@ -132,6 +132,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-0001-fix-kepler-compute_arch-if-CUDA-toolkit-11-is-used.patch
"${FILESDIR}"/${PN}-8.2.0-freetype-2.10.3-provide-FT_CALLBACK_DEF.patch
+ "${FILESDIR}"/${PN}-9.0.1-limits-include-gcc11.patch
)
DOCS=( CONTRIBUTING.md README.md )