summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-05-05 11:24:45 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-05-05 11:26:18 +0200
commit1256a483f24cebcb72afa419436f1ec6d8bc3916 (patch)
tree3b8ca2279c94af71ca9cc2c3d5720617de7108c0 /sci-libs
parentx11-terms/st: prefer explicit string check (diff)
downloadgentoo-1256a483f24cebcb72afa419436f1ec6d8bc3916.tar.gz
gentoo-1256a483f24cebcb72afa419436f1ec6d8bc3916.tar.bz2
gentoo-1256a483f24cebcb72afa419436f1ec6d8bc3916.zip
sci-libs/onnx: require python always
Closes: https://bugs.gentoo.org/931229 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/onnx-1.15.0-r3.ebuild (renamed from sci-libs/onnx/onnx-1.15.0-r2.ebuild)45
1 files changed, 25 insertions, 20 deletions
diff --git a/sci-libs/onnx/onnx-1.15.0-r2.ebuild b/sci-libs/onnx/onnx-1.15.0-r3.ebuild
index 63e8ab1695e9..cd9731d69130 100644
--- a/sci-libs/onnx/onnx-1.15.0-r2.ebuild
+++ b/sci-libs/onnx/onnx-1.15.0-r3.ebuild
@@ -3,7 +3,6 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_OPTIONAL=1
DISTUTILS_EXT=1
PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 cmake
@@ -16,47 +15,53 @@ SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-IUSE="python"
RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- )
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
dev-libs/protobuf:=
"
DEPEND="${RDEPEND}"
-BDEPEND="python? (
- ${DISTUTILS_DEPS}
-)"
-
-PATCHES=( "${FILESDIR}"/${P}-hidden.patch )
-
src_prepare() {
+ eapply "${FILESDIR}"/${P}-hidden.patch
cmake_src_prepare
- use python && distutils-r1_src_prepare
+ distutils-r1_src_prepare
}
-src_configure() {
+python_configure_all()
+{
mycmakeargs=(
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
-DONNX_USE_LITE_PROTO=ON
-DONNX_BUILD_SHARED_LIBS=ON
)
cmake_src_configure
- use python && distutils-r1_src_configure
+}
+
+src_configure() {
+ distutils-r1_src_configure
}
src_compile() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ )
+ CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+python_compile_all() {
cmake_src_compile
- use python && CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
}
-src_install() {
+python_install_all() {
cmake_src_install
- use python && distutils-r1_src_install
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
}