summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-15 02:08:32 +0000
committerSam James <sam@gentoo.org>2020-12-15 02:13:08 +0000
commit18f089b336e3dd952ac07a8571d578cf65ca530d (patch)
treee2e0bb88a2533b39f182c9849c2debf4e18beebe /sci-libs
parentsci-libs/vtk: fix finding pugixml (diff)
downloadgentoo-18f089b336e3dd952ac07a8571d578cf65ca530d.tar.gz
gentoo-18f089b336e3dd952ac07a8571d578cf65ca530d.tar.bz2
gentoo-18f089b336e3dd952ac07a8571d578cf65ca530d.zip
sci-libs/vtk: further >=dev-libs/pugixml-1.11 fixes
* Drop the internal copy of pugixml just in case. * Adapt vtk to the new "proper" CMake config files from pugixml upstream. Note that Aisha Tammy's patch worked for her with CMake 3.19.1 but not for me on 3.17.4 (stable), so this seems to be needed to be safe. Bug: https://bugs.gentoo.org/758611 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/files/vtk-8.2.0-pugixml.patch13
-rw-r--r--sci-libs/vtk/vtk-8.2.0-r1.ebuild6
2 files changed, 11 insertions, 8 deletions
diff --git a/sci-libs/vtk/files/vtk-8.2.0-pugixml.patch b/sci-libs/vtk/files/vtk-8.2.0-pugixml.patch
index 3c72bcf0003b..d890f696388d 100644
--- a/sci-libs/vtk/files/vtk-8.2.0-pugixml.patch
+++ b/sci-libs/vtk/files/vtk-8.2.0-pugixml.patch
@@ -1,13 +1,12 @@
-diff --git a/IO/CityGML/CMakeLists.txt b/IO/CityGML/CMakeLists.txt
-index ce979ba..555f205 100644
+https://bugs.gentoo.org/758611
--- a/IO/CityGML/CMakeLists.txt
+++ b/IO/CityGML/CMakeLists.txt
-@@ -5,7 +5,7 @@ vtk_module_library(vtkIOCityGML ${Module_SRCS})
+@@ -5,7 +5,4 @@ vtk_module_library(vtkIOCityGML ${Module_SRCS})
if(VTK_USE_SYSTEM_PUGIXML AND NOT pugixml_INCLUDE_DIRS)
find_package(pugixml REQUIRED)
- get_target_property(pugixml_INCLUDE_DIRS pugixml INTERFACE_INCLUDE_DIRECTORIES)
+- get_target_property(pugixml_INCLUDE_DIRS pugixml INTERFACE_INCLUDE_DIRECTORIES)
- get_target_property(pugixml_LIBRARIES pugixml LOCATION)
-+ get_target_property(pugixml_LIBRARIES pugixml INTERFACE_LINK_LIBRARIES)
- include_directories(${pugixml_INCLUDE_DIRS})
- vtk_module_link_libraries(vtkIOCityGML LINK_PRIVATE ${pugixml_LIBRARIES})
+- include_directories(${pugixml_INCLUDE_DIRS})
+- vtk_module_link_libraries(vtkIOCityGML LINK_PRIVATE ${pugixml_LIBRARIES})
++ vtk_module_link_libraries(vtkIOCityGML LINK_PRIVATE pugixml::pugixml)
endif()
diff --git a/sci-libs/vtk/vtk-8.2.0-r1.ebuild b/sci-libs/vtk/vtk-8.2.0-r1.ebuild
index c5fa5e5ead49..d0d4b52214cf 100644
--- a/sci-libs/vtk/vtk-8.2.0-r1.ebuild
+++ b/sci-libs/vtk/vtk-8.2.0-r1.ebuild
@@ -146,12 +146,15 @@ src_prepare() {
local x
# missing: VPIC freerange libproj4 mrmpi sqlite utf8 verdict xmdf2 xmdf3
- for x in expat freetype hdf5 jpeg jsoncpp libharu libxml2 lz4 netcdf png tiff zlib; do
+ for x in expat freetype hdf5 jpeg jsoncpp libharu libxml2 lz4 netcdf pugixml png tiff zlib; do
ebegin "Dropping bundled ${x}"
rm -r ThirdParty/${x}/vtk${x} || die
eend $?
done
+ sed -i -e '/add_subdirectory(vtkpugixml)/d' ThirdParty/pugixml/CMakeLists.txt || die
+ sed -i -e '/vtk_target_export(vtkpugixml)/d' ThirdParty/pugixml/CMakeLists.txt || die
+
if use doc; then
einfo "Removing .md5 files from documents."
rm -f "${WORKDIR}"/html/*.md5 || die "Failed to remove superfluous hashes"
@@ -184,6 +187,7 @@ src_configure() {
-DVTK_USE_SYSTEM_LibXml2=ON
-DVTK_USE_SYSTEM_NETCDF=ON
-DVTK_USE_SYSTEM_OGGTHEORA=ON
+ -DVTK_USE_SYSTEM_PUGIXML=ON
-DVTK_USE_SYSTEM_PNG=ON
-DVTK_USE_SYSTEM_TIFF=ON
-DVTK_USE_SYSTEM_TWISTED=ON