summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-27 23:06:08 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-27 23:06:08 +0200
commit1c1cdf37123151f9c70100b1f036c940c9c4f02d (patch)
tree636c30f3c6919be2406ba0c541bacb839cf6cac4 /sci-libs
parentgames-strategy/naev: Port to python3_10 (diff)
downloadgentoo-1c1cdf37123151f9c70100b1f036c940c9c4f02d.tar.gz
gentoo-1c1cdf37123151f9c70100b1f036c940c9c4f02d.tar.bz2
gentoo-1c1cdf37123151f9c70100b1f036c940c9c4f02d.zip
sci-libs/libxc: Bump to 5.1.4
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libxc/Manifest1
-rw-r--r--sci-libs/libxc/libxc-5.1.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index d181e372988d..b1342a6a7de5 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,3 @@
DIST libxc-5.1.0.tar.gz 42951890 BLAKE2B 32ce8d15547882455e01cbf9d4ee8780b97059d5b710f25b799779a5efe7326c376a53111102f3d5e0853bb89ba1f4dd9c2f219cfb4d3f91a2f6e1100f8fb47a SHA512 615b82290e87a48484f6dbe41cd8f1538ba6201b99fc97be2db64b66232fa4349fe6cebfb51566098db3cabd7aff662bb7ace43a811507bff2e93afd03d56ce4
DIST libxc-5.1.1.tar.gz 43264474 BLAKE2B 887dc11a6385559edc5e2e62f3e00b16ff5695e1c384196bc3efe5aceff0a223d5f69fafaa08290bdf72f95390cb82d43e541ffaf6c4569e850eed3cb63aa5f6 SHA512 467ff09c39df30ccd50447dda5bbfe9e5f3e8f2876e069b6c16d49b3cfcc8b45316640f5b16c56ff7645355be9ec4dc571c794a17accb7731cd22bcce53f8b99
+DIST libxc-5.1.4.tar.gz 43036222 BLAKE2B 10348ccd2e8e512bf576a03eb19bf714ae4f0e590ae3a7266ae8f46c42ee12ef91e049f0007ce42023e7f13c865fedef6d1ab0fb76195ca47f62a50702741c49 SHA512 ef7f44e773a0a8a9c1a53ddd12301e123f9a4606f22420cf011d579314c1bf3164b82299aca0ef32cb130b380e5e9534d4fcc658c549ac4cb8b6f86d025cfe1e
diff --git a/sci-libs/libxc/libxc-5.1.4.ebuild b/sci-libs/libxc/libxc-5.1.4.ebuild
new file mode 100644
index 000000000000..884100437a30
--- /dev/null
+++ b/sci-libs/libxc/libxc-5.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="https://octopus-code.org/wiki/Libxc"
+SRC_URI="https://gitlab.com/libxc/libxc/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran test"
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+ dodoc ChangeLog.md
+
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
+}