summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-16 05:51:12 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-11 09:31:54 +0200
commit202a693441376765277704d514f3baa2523d0a73 (patch)
tree5f96bf3a40cd64ae28c2066cff1c0a737dfb2411 /sci-libs
parentsci-electronics/splat: Fix error: ISO C++17 does not allow register storage c... (diff)
downloadgentoo-202a693441376765277704d514f3baa2523d0a73.tar.gz
gentoo-202a693441376765277704d514f3baa2523d0a73.tar.bz2
gentoo-202a693441376765277704d514f3baa2523d0a73.zip
sci-libs/getdata: Fix error: call to undeclared function gzseek64
Closes: https://bugs.gentoo.org/898278 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31476 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/files/getdata-0.11.0-fix-gzseek64-not-found.patch12
-rw-r--r--sci-libs/getdata/getdata-0.11.0-r1.ebuild63
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/getdata/files/getdata-0.11.0-fix-gzseek64-not-found.patch b/sci-libs/getdata/files/getdata-0.11.0-fix-gzseek64-not-found.patch
new file mode 100644
index 000000000000..09a250e955f9
--- /dev/null
+++ b/sci-libs/getdata/files/getdata-0.11.0-fix-gzseek64-not-found.patch
@@ -0,0 +1,12 @@
+Refer: https://stackoverflow.com/a/42695228
+Bug: https://bugs.gentoo.org/898278
+--- a/src/gzip.c
++++ b/src/gzip.c
+@@ -21,6 +21,7 @@
+ #include "internal.h"
+
+ #ifdef HAVE_ZLIB_H
++#define Z_LARGE64
+ #include <zlib.h>
+ #endif
+
diff --git a/sci-libs/getdata/getdata-0.11.0-r1.ebuild b/sci-libs/getdata/getdata-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..698d2697d850
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.11.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_STANDARD="95"
+FORTRAN_NEEDED=fortran
+inherit autotools fortran-2 flag-o-matic
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="https://getdata.sourceforge.net"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 cxx debug flac fortran lzma perl static-libs"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-fix-gzseek64-not-found.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # GCC 10 workaround
+ # bug #723076
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ econf \
+ --disable-idl \
+ --disable-matlab \
+ --disable-php \
+ --with-libz \
+ --without-libslim \
+ --without-libzzip \
+ $(use_with bzip2 libbz2) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable debug) \
+ $(use_with flac libFLAC) \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
+ $(use_with lzma liblzma) \
+ $(use_enable perl) \
+ $(usex perl --with-perl-dir=vendor) \
+ --disable-python \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}