summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-12 18:08:59 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-12 20:45:59 +0200
commit2332003973da6b9c6441f93448df4785f053ce68 (patch)
tree43474570971b2431c22f934d66909f146e887673 /sci-libs
parentsci-libs/rtree: fixed wrong profile updates file (diff)
downloadgentoo-2332003973da6b9c6441f93448df4785f053ce68.tar.gz
gentoo-2332003973da6b9c6441f93448df4785f053ce68.tar.bz2
gentoo-2332003973da6b9c6441f93448df4785f053ce68.zip
sci-libs/rtree-0.9.4: fixed missing dependency for tests
Closes: https://bugs.gentoo.org/747883 Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rtree/rtree-0.9.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/rtree/rtree-0.9.4-r1.ebuild b/sci-libs/rtree/rtree-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..a0940fd1901a
--- /dev/null
+++ b/sci-libs/rtree/rtree-0.9.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="Rtree"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://rtree.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="sci-libs/libspatialindex"
+
+distutils_enable_sphinx docs/source
+
+distutils_enable_tests pytest
+
+DEPEND+="
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"