summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-16 21:49:20 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-16 23:49:22 +0200
commit2ae1f9ac47eca2f9bc9f761ea166d5aa2e31b1fd (patch)
treeec1e2473a33b1b9e1e5e42d2070f39a4bb8ecb58 /sci-libs
parentsci-libs/libh2o: Migrate to GitHub (diff)
downloadgentoo-2ae1f9ac47eca2f9bc9f761ea166d5aa2e31b1fd.tar.gz
gentoo-2ae1f9ac47eca2f9bc9f761ea166d5aa2e31b1fd.tar.bz2
gentoo-2ae1f9ac47eca2f9bc9f761ea166d5aa2e31b1fd.zip
sci-libs/libh2o: Bump to EAPI 7
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libh2o/libh2o-0.2.1-r1.ebuild29
-rw-r--r--sci-libs/libh2o/libh2o-9999.ebuild21
2 files changed, 44 insertions, 6 deletions
diff --git a/sci-libs/libh2o/libh2o-0.2.1-r1.ebuild b/sci-libs/libh2o/libh2o-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..2b52c92af381
--- /dev/null
+++ b/sci-libs/libh2o/libh2o-0.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library of routines for IF97 water & steam properties"
+HOMEPAGE="https://github.com/mgorny/libh2o/"
+SRC_URI="https://github.com/mgorny/libh2o/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/libh2o/libh2o-9999.ebuild b/sci-libs/libh2o/libh2o-9999.ebuild
index 2181109f3660..731e477a3910 100644
--- a/sci-libs/libh2o/libh2o-9999.ebuild
+++ b/sci-libs/libh2o/libh2o-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils git-r3
+inherit autotools git-r3
DESCRIPTION="Library of routines for IF97 water & steam properties"
HOMEPAGE="https://github.com/mgorny/libh2o/"
@@ -19,10 +17,21 @@ IUSE="debug static-libs"
DEPEND="virtual/pkgconfig"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable debug)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}