summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-13 23:15:30 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-13 23:15:30 +0100
commit35b5e314c699fe1b4ff547f301938fd603fdd764 (patch)
tree58c166ec1ad634ad1f3618feaee3bc7f4002f44c /sci-libs
parentdev-ml/ocaml-migrate-parsetree: fix dep on ocaml (diff)
downloadgentoo-35b5e314c699fe1b4ff547f301938fd603fdd764.tar.gz
gentoo-35b5e314c699fe1b4ff547f301938fd603fdd764.tar.bz2
gentoo-35b5e314c699fe1b4ff547f301938fd603fdd764.zip
sci-libs/kineto: add 0.4.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/kineto/Manifest1
-rw-r--r--sci-libs/kineto/kineto-0.4.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/kineto/Manifest b/sci-libs/kineto/Manifest
index f95e98c70918..16d4c81d737e 100644
--- a/sci-libs/kineto/Manifest
+++ b/sci-libs/kineto/Manifest
@@ -1 +1,2 @@
+DIST kineto-0.4.0.tar.gz 8190627 BLAKE2B 015017096b6a01b2f2172580884aef6c57df0d33c3d8904c959acc7f7dcc36386f72acb9a672571fa25b7f74c1d2d763692b8cc5a634a73ac143819f811737df SHA512 4a3cbf2f29aa174b9a67f55d0f4e7b8d952ed5dba612f33d144a4d019055031e2a6ff8c98ef1971bf2508460cb871dace38bfc669c10c076cc42d685a1842d86
DIST kineto-2021.11.17.tar.gz 7497956 BLAKE2B b15573ab63ed0f2e09658a2d7fdd0746a659eb61ca48e996ef471f56af0be3a2778be8c1e93af69efe9d35e52090711ea7cce433988fa3ef1b7c9be8087bfda6 SHA512 bf237e66e44da9fbdf90e7bbf347ae68453cebb3c34c753472eeeeca27d22c0fa1e672dc148ec6394108146d10d1ee77d420cdc2397902fe457aa085643b9714
diff --git a/sci-libs/kineto/kineto-0.4.0.ebuild b/sci-libs/kineto/kineto-0.4.0.ebuild
new file mode 100644
index 000000000000..60ac97c00887
--- /dev/null
+++ b/sci-libs/kineto/kineto-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 cmake
+
+DESCRIPTION="part of the PyTorch Profiler"
+HOMEPAGE="https://github.com/pytorch/kineto"
+SRC_URI="https://github.com/pytorch/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libfmt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ ${PYTHON_DEPS}
+"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-2021.11.17-gentoo.patch
+ cd libkineto
+ cmake_src_prepare
+}
+
+src_configure() {
+ cd libkineto
+ cmake_src_configure
+}