summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-25 23:00:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-25 23:00:21 +0300
commit36e59ad6e56c8fa91ce92d72ae8d61d71b04437b (patch)
tree356dfcfae808b049c4935637d3528b81f133c2a4 /sci-libs
parentnet-dns/idnkit: EAPI 6 -> 8 (diff)
downloadgentoo-36e59ad6e56c8fa91ce92d72ae8d61d71b04437b.tar.gz
gentoo-36e59ad6e56c8fa91ce92d72ae8d61d71b04437b.tar.bz2
gentoo-36e59ad6e56c8fa91ce92d72ae8d61d71b04437b.zip
sci-libs/beagle: EAPI=8, cleanup, fix C++17
Closes: https://bugs.gentoo.org/898274 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/beagle/beagle-3.0.3-r2.ebuild (renamed from sci-libs/beagle/beagle-3.0.3-r1.ebuild)21
1 files changed, 10 insertions, 11 deletions
diff --git a/sci-libs/beagle/beagle-3.0.3-r1.ebuild b/sci-libs/beagle/beagle-3.0.3-r2.ebuild
index 1061e0012dc8..72dde6ac1f03 100644
--- a/sci-libs/beagle/beagle-3.0.3-r1.ebuild
+++ b/sci-libs/beagle/beagle-3.0.3-r2.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Open BEAGLE, a versatile EC/GA/GP framework"
-SRC_URI="mirror://sourceforge/beagle/${P}.tar.gz"
HOMEPAGE="https://chgagne.github.io/beagle/"
+SRC_URI="mirror://sourceforge/beagle/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples static-libs"
-RDEPEND="
- sys-libs/zlib
- !app-misc/beagle
- !dev-libs/libbeagle"
-DEPEND="${RDEPEND}
- doc? ( app-text/doxygen )"
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-text/doxygen )"
PATCHES=(
"${FILESDIR}/${PN}-3.0.3-gcc43.patch"
@@ -27,8 +24,10 @@ PATCHES=(
src_prepare() {
default
- sed -e "s:@LIBS@:@LIBS@ -lpthread:" \
- -i PACC/Threading/Makefile.in || die
+ sed -e "s:@LIBS@:& -lpthread:" -i PACC/Threading/Makefile.in || die
+
+ # fix build with C++17, bug #898274
+ sed -e "s/register //" -i PACC/Util/{MTRand.hpp,Tokenizer.cpp} || die
}
src_configure() {