summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 12:47:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-09 13:30:25 +0200
commit43092c487ed3356e2e74219fc1e80b270975a0ff (patch)
tree8fc86186c3cc4241e670fcc8eb01fc252000efc5 /sci-libs
parentmedia-libs/libsndfile: Add patch for pointer aliasing (diff)
downloadgentoo-43092c487ed3356e2e74219fc1e80b270975a0ff.tar.gz
gentoo-43092c487ed3356e2e74219fc1e80b270975a0ff.tar.bz2
gentoo-43092c487ed3356e2e74219fc1e80b270975a0ff.zip
sci-libs/getdata: Eradicate python2
Closes: https://bugs.gentoo.org/735480 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/getdata-0.9.0-r3.ebuild23
1 files changed, 4 insertions, 19 deletions
diff --git a/sci-libs/getdata/getdata-0.9.0-r3.ebuild b/sci-libs/getdata/getdata-0.9.0-r3.ebuild
index bb727d3bea89..9282f0156853 100644
--- a/sci-libs/getdata/getdata-0.9.0-r3.ebuild
+++ b/sci-libs/getdata/getdata-0.9.0-r3.ebuild
@@ -5,8 +5,7 @@ EAPI=6
FORTRAN_STANDARD="95"
FORTRAN_NEEDED=fortran
-PYTHON_COMPAT=( python2_7 )
-inherit autotools fortran-2 python-single-r1
+inherit autotools fortran-2
DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
HOMEPAGE="http://getdata.sourceforge.net/"
@@ -15,31 +14,17 @@ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.xz"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 cxx debug flac fortran lzma perl python static-libs"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="bzip2 cxx debug flac fortran lzma perl static-libs"
DEPEND="
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
perl? ( dev-lang/perl )
- python? (
- $(python_gen_cond_dep '
- || (
- dev-python/numpy-python2[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- )
- ')
- ${PYTHON_DEPS}
- )"
+"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}-remove-python-test.patch" )
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
src_prepare() {
default
eautoreconf
@@ -62,7 +47,7 @@ src_configure() {
$(use_with lzma liblzma) \
$(use_enable perl) \
$(usex perl --with-perl-dir=vendor) \
- $(use_enable python) \
+ --disable-python \
$(use_enable static-libs static)
}