summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-07-23 10:42:28 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-08-21 18:13:18 +0200
commit4542551ff511e1d11282c5208f383e19dd944f43 (patch)
tree07a54814d7f7c6148b54453ab4125c7a58dff6d9 /sci-libs
parentdev-perl/File-BaseDir: Bump to version 0.80.0 (diff)
downloadgentoo-4542551ff511e1d11282c5208f383e19dd944f43.tar.gz
gentoo-4542551ff511e1d11282c5208f383e19dd944f43.tar.bz2
gentoo-4542551ff511e1d11282c5208f383e19dd944f43.zip
sci-libs/fcl: bump to 0.6.1
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16787 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fcl/Manifest1
-rw-r--r--sci-libs/fcl/fcl-0.6.1.ebuild72
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild65
-rw-r--r--sci-libs/fcl/metadata.xml11
4 files changed, 129 insertions, 20 deletions
diff --git a/sci-libs/fcl/Manifest b/sci-libs/fcl/Manifest
index fa81dab24cc6..b180d0a77df9 100644
--- a/sci-libs/fcl/Manifest
+++ b/sci-libs/fcl/Manifest
@@ -1 +1,2 @@
DIST fcl-0.5.0.tar.gz 5760425 BLAKE2B 5eac7ace3801740a6317bcc558199b5791e3e5c4fbd63305e5173597b1ecf647388a92bc894629598f963aacd0dd6f894717ae76b3bf7fc9c62a55d9330caf20 SHA512 8741c664720cb32e368e0139881ce69c29e3ccb9633ddc22f47b89918774dbc19541c68e1dbfd78a91f4c8c226ad4c0e1867b6e62111d4311fe907310fc71794
+DIST fcl-0.6.1.tar.gz 6208928 BLAKE2B 174176b3844b18ada60884f641c49475357b1c25cb58cdfc1c4545d595add58713020ffaf148676dae14eca87397495cc971423f06fd19af5cffac1bde584603 SHA512 9d5382c1f2701f2cc6988b3e3969f44c401ea0eb4fdfc5ae69c27dd5bb59a0f17de82ef49e7dce0e1fd91a133db6f10aef9581ca2e32b919046f72921593ebf4
diff --git a/sci-libs/fcl/fcl-0.6.1.ebuild b/sci-libs/fcl/fcl-0.6.1.ebuild
new file mode 100644
index 000000000000..8c1a80c0eb37
--- /dev/null
+++ b/sci-libs/fcl/fcl-0.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+DESCRIPTION="The Flexible Collision Library"
+HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
+LICENSE="BSD"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost:=[threads]
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # Upstream issue:
+ # https://github.com/flexible-collision-library/fcl/issues/485
+ rm "${S}"/test/narrowphase/detail/convexity_based_algorithm/test_gjk_libccd-inl_gjk_doSimplex2.cpp
+ sed -i -e 's/test_gjk_libccd-inl_gjk_doSimplex2.cpp//' "${S}"/test/narrowphase/detail/convexity_based_algorithm/CMakeLists.txt || die could not disable failing test
+
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
+}
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
index 6d823b172040..fe367b10808f 100644
--- a/sci-libs/fcl/fcl-9999.ebuild
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -1,41 +1,66 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
-fi
-
-inherit ${SCM} cmake-utils
+inherit cmake
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
- SRC_URI=""
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/flexible-collision-library/${PN}.git"
+ inherit git-r3
else
+ SRC_URI="https://github.com/flexible-collision-library/fcl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="The Flexible Collision Library"
HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
+
LICENSE="BSD"
-SLOT="0"
-IUSE="cpu_flags_x86_sse"
+SLOT="0/6"
+IUSE="cpu_flags_x86_sse doc +octomap profiling test"
+RESTRICT="!test? ( test )"
RDEPEND="
- sci-libs/octomap
- sci-libs/flann
+ dev-cpp/eigen:3
dev-libs/boost:=[threads]
- sci-libs/libccd"
+ sci-libs/flann
+ sci-libs/libccd[double-precision]
+ octomap? ( sci-libs/octomap )"
+
DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
+ sed -i -e "s/include(CompilerSettings)//" "${S}"/CMakeLists.txt || die "failed to remove compiler flags override"
+
local mycmakeargs=(
- "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DFCL_COVERALLS=OFF
+ -DFCL_COVERALLS_UPLOAD=OFF
+ -DFCL_ENABLE_PROFILING=$(usex profiling ON OFF)
+ -DFCL_TREAT_WARNINGS_AS_ERRORS=OFF
+ -DFCL_USE_HOST_NATIVE_ARCH=OFF
+ -DFCL_USE_X64_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DFCL_WITH_OCTOMAP=$(usex octomap ON OFF)
)
- cmake-utils_src_configure
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && HTML_DOCS=( "${S}"/doc/doxygen/html )
+ einstalldocs
}
diff --git a/sci-libs/fcl/metadata.xml b/sci-libs/fcl/metadata.xml
index fbedec0d5c16..35079633a42a 100644
--- a/sci-libs/fcl/metadata.xml
+++ b/sci-libs/fcl/metadata.xml
@@ -5,7 +5,18 @@
<email>aballier@gentoo.org</email>
<name>Alexis Ballier</name>
</maintainer>
+ <longdescription>
+ FCL is a library for performing three types of proximity queries on a pair of geometric models composed of triangles.
+ </longdescription>
+ <use>
+ <flag name="octomap">OctoMap library support</flag>
+ <flag name="profiling">Enable profiling</flag>
+ </use>
+ <slots>
+ <subslots>Soname version number of fcl</subslots>
+ </slots>
<upstream>
+ <bugs-to>https://github.com/lexible-collision-library/fcl/issues</bugs-to>
<remote-id type="github">flexible-collision-library/fcl</remote-id>
</upstream>
</pkgmetadata>