summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-01-20 12:46:40 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-01-20 15:43:48 -0500
commit470ee9af9d6228072651426e7eefd06dc3c45a72 (patch)
tree0a46ad5993e18d12f9273f90e966abe21c2147ae /sci-libs
parentinstall-qa-check.d: disallow "nix" and "gnu" as top-level paths. (diff)
downloadgentoo-470ee9af9d6228072651426e7eefd06dc3c45a72.tar.gz
gentoo-470ee9af9d6228072651426e7eefd06dc3c45a72.tar.bz2
gentoo-470ee9af9d6228072651426e7eefd06dc3c45a72.zip
sci-libs/symmetrica: new C library for representation theory and more.
This package has been forked under the SageMath umbrella, and the build system has been overhauled to the point that maintaining it will not be a punishment. The new v3.0.1 is the first release of the fork if you pretend that v3.0.0 never happened (I forgot to include the documentation in the release tarball). The upstream SageMath project can detect and use the system copy of symmetrica now, so this will allow Gentoo users of SageMath to avoid pointless rebuilds of symmetrica. Closes: https://bugs.gentoo.org/232014 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/symmetrica/Manifest1
-rw-r--r--sci-libs/symmetrica/metadata.xml24
-rw-r--r--sci-libs/symmetrica/symmetrica-3.0.1.ebuild24
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-libs/symmetrica/Manifest b/sci-libs/symmetrica/Manifest
new file mode 100644
index 000000000000..9370fd11f54e
--- /dev/null
+++ b/sci-libs/symmetrica/Manifest
@@ -0,0 +1 @@
+DIST symmetrica-3.0.1.tar.xz 789336 BLAKE2B 88521356bdc006413e0922b49b23f345da96bbe8cb2a4a6ae12bf53fe46150078f086e6d1f6e514817453f2a868b6eb578b716c05f5459397ed8d766d321ec24 SHA512 1e4c42e1ae9fcdf246dff1c1f01522d6cd416c12302363f82356018847df2f64d2f5ea6256459832d195e8e333ae14743794d5a53346e92d8ba1bb1c0949c271
diff --git a/sci-libs/symmetrica/metadata.xml b/sci-libs/symmetrica/metadata.xml
new file mode 100644
index 000000000000..3704ab7e98b1
--- /dev/null
+++ b/sci-libs/symmetrica/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="gitlab">https://gitlab.com/sagemath/symmetrica</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/symmetrica/symmetrica-3.0.1.ebuild b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
new file mode 100644
index 000000000000..eab633507c88
--- /dev/null
+++ b/sci-libs/symmetrica/symmetrica-3.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C library for representation theory, combinatorics, and more"
+HOMEPAGE="https://gitlab.com/sagemath/symmetrica"
+SRC_URI="https://gitlab.com/sagemath/symmetrica/uploads/b3d8e1ad5ab2449c30bbc3147e7a5e53/symmetrica-3.0.1.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DOCS=( README.md )
+
+src_configure(){
+ econf $(use_enable doc)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}