summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-01-31 09:36:45 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-01-31 13:15:20 -0700
commit48e49ab3291c7b69e38070be1c23e4e44340803f (patch)
treecfd90a7b72e59734851cd5688c9bf68680b685d5 /sci-libs
parentx11-wm/awesome: 4.3 bump, restrict tests in awesome-4 as well (diff)
downloadgentoo-48e49ab3291c7b69e38070be1c23e4e44340803f.tar.gz
gentoo-48e49ab3291c7b69e38070be1c23e4e44340803f.tar.bz2
gentoo-48e49ab3291c7b69e38070be1c23e4e44340803f.zip
sci-libs/votca-tools: version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/votca-tools/Manifest1
-rw-r--r--sci-libs/votca-tools/votca-tools-1.5.ebuild57
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild3
3 files changed, 59 insertions, 2 deletions
diff --git a/sci-libs/votca-tools/Manifest b/sci-libs/votca-tools/Manifest
index d4a52de49b7a..fcff568f841d 100644
--- a/sci-libs/votca-tools/Manifest
+++ b/sci-libs/votca-tools/Manifest
@@ -1,2 +1,3 @@
DIST votca-tools-1.4.1.tar.gz 103152 BLAKE2B 73dc726ea899ceb65d0406f3795f1df79a6184d65e50e95be3768678a2d006b75e487dbe3df5d44be4b5ba3899aeeb01ed63b51755bd46b546b017ccc0406d38 SHA512 19165be7c9903cb664051a6556f9fd689b02af71156f040960008e8d74e4a32adfe283c67eb7b53c8bdc6ae6f72516ad0b674d9f2b3354ca50f082b1651dafef
DIST votca-tools-1.4.tar.gz 103102 BLAKE2B a398d20b628148ec753ee1e59353e272dbda93848be11ecccaf2153385ebcac62c7b819c4ef0b9b1a7cfc7dfd85136d042726cc996af79a4dad64375f5aa9f6c SHA512 7c4bf2e2ba8cf795f03879138787db3875f48db56b88394c98b18cef0ae90e636d8aafff42eb62a408df06a91583e37e59b33440e83de9f4338295e9ccfc9be5
+DIST votca-tools-1.5.tar.gz 129464 BLAKE2B 2ab72758cc7c9bed5a49c924f7f0a93dc562a43cefbcc84f393656fd6c6b165152114eab48131db4d42008472d01103b5abba6ae0cf12779fe1ffacbcd65dc11 SHA512 fdee932c861742961937bdb88a1ace8caa4041c38ce80ece3b27e8a4b624248c21bf9be63b157565d1114047d3895c8b959f95b4fa49225c0cd1b2e708ef54f0
diff --git a/sci-libs/votca-tools/votca-tools-1.5.ebuild b/sci-libs/votca-tools/votca-tools-1.5.ebuild
new file mode 100644
index 000000000000..a0839fa8779c
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils eutils multilib
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc +fftw sqlite"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-cpp/eigen-3.3
+ fftw? ( sci-libs/fftw:3.0 )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( NOTICE )
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_FFTW=$(usex fftw)
+ -DWITH_SQLITE3=$(usex sqlite)
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ cmake-utils_src_make html
+ dodoc -r share/doc/html
+ fi
+}
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 470ee69553d5..a0839fa8779c 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -43,7 +43,6 @@ src_configure() {
-DWITH_FFTW=$(usex fftw)
-DWITH_SQLITE3=$(usex sqlite)
-DWITH_RC_FILES=OFF
- -DLIB=$(get_libdir)
)
cmake-utils_src_configure
}