summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-10-13 16:16:00 +0200
committerSam James <sam@gentoo.org>2022-10-13 23:48:23 +0100
commit4c869d37dccaef9a0454ec688a4d3f48fb60075b (patch)
treeb58c7d6f66ec03f6447479e2fa005227d26ea647 /sci-libs
parentmedia-libs/imlib2: Stabilize 1.7.5 arm, #862528 (diff)
downloadgentoo-4c869d37dccaef9a0454ec688a4d3f48fb60075b.tar.gz
gentoo-4c869d37dccaef9a0454ec688a4d3f48fb60075b.tar.bz2
gentoo-4c869d37dccaef9a0454ec688a4d3f48fb60075b.zip
sci-libs/pdal: fix test
Closes: https://bugs.gentoo.org/876981 Closes: https://github.com/gentoo/gentoo/pull/27769 Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pdal/files/pdal-2.4.3-fix-test.patch24
-rw-r--r--sci-libs/pdal/pdal-2.4.3.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/pdal/files/pdal-2.4.3-fix-test.patch b/sci-libs/pdal/files/pdal-2.4.3-fix-test.patch
new file mode 100644
index 000000000000..e49c2f129f11
--- /dev/null
+++ b/sci-libs/pdal/files/pdal-2.4.3-fix-test.patch
@@ -0,0 +1,24 @@
+From https://github.com/PDAL/PDAL/commit/88d6825751434a97795d0f65b28d66e3a986f2c4.patch Mon Sep 17 00:00:00 2001
+From: Howard Butler <hobu.inc@gmail.com>
+Date: Fri, 16 Sep 2022 08:10:16 -0500
+Subject: [PATCH 01/39] relax WKT checking test now that PROJ 9+ adds AUTHORITY
+ bits to more things
+
+---
+ test/unit/io/LasReaderTest.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/unit/io/LasReaderTest.cpp b/test/unit/io/LasReaderTest.cpp
+index cbc8fab04d..5715039f90 100644
+--- a/test/unit/io/LasReaderTest.cpp
++++ b/test/unit/io/LasReaderTest.cpp
+@@ -270,7 +270,7 @@ TEST(LasReaderTest, inspect)
+ // This string is common for WKT1 and WKT2. When we move to WKT2
+ // completely, this can be fixed.
+ std::string testWkt {
+- R"(GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0],UNIT["degree",0.0174532925199433)"
++ R"(GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]])"
+ };
+
+ EXPECT_TRUE(Utils::startsWith(qi.m_srs.getWKT(), testWkt));
+
diff --git a/sci-libs/pdal/pdal-2.4.3.ebuild b/sci-libs/pdal/pdal-2.4.3.ebuild
index 9bd82c4dc76e..12e0180b0b45 100644
--- a/sci-libs/pdal/pdal-2.4.3.ebuild
+++ b/sci-libs/pdal/pdal-2.4.3.ebuild
@@ -37,6 +37,10 @@ DEPEND="
S="${WORKDIR}/PDAL-${PV}-src"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-test.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"