summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-06-30 11:48:17 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-06-30 13:19:26 -0500
commit4ec4eb3c96861cfc89b7884bc9ec13b2bd1d4410 (patch)
tree9814f614a9b64022a8c58da046ff13664a4b9fd1 /sci-libs
parentdev-util/cppcheck: version bump to 1.88 (diff)
downloadgentoo-4ec4eb3c96861cfc89b7884bc9ec13b2bd1d4410.tar.gz
gentoo-4ec4eb3c96861cfc89b7884bc9ec13b2bd1d4410.tar.bz2
gentoo-4ec4eb3c96861cfc89b7884bc9ec13b2bd1d4410.zip
sci-libs/libqalculate: version bump to 3.2.0
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-3.2.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index e9ceef9c3169..969f811ebebc 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1,3 +1,4 @@
DIST libqalculate-0.9.9.tar.gz 1509180 BLAKE2B 3f309add80ddb6b21730eab25d37c2d8fee163a79768a09ec5e7e5d329aa11ed9dafbf77f4ce194a96c2ac6a3b55a9c0d16755d5e106123cc2a5f931f6872d91 SHA512 c7692dcd91e0a7aea8184ca5366a3caf704b6e716c9e8552f4214ce7fc3157cf127daf7a063196383e4d5a99f8703486f2282c7fb01acafee5e1b3d8993de384
DIST libqalculate-2.2.0.tar.gz 1717207 BLAKE2B 020ca544683ff140ab5f8256a5a955c895a6ea09a581e9e75ab6c0a0657886c352a1ec2d34400057fe80004481d3198998613113ca40fb4feebfca010445dced SHA512 e6f3693e4dba2beffca300b673657b90037a6b7acc5bbd4e659863f4f5aec148d6d385fc3c666b16b2be713d0a8ad1b4d7fda557cef0e2be340ca2435f62aae7
DIST libqalculate-2.8.1.tar.gz 1961535 BLAKE2B 074d83a44cbc6cb5d8afe5121e4c34cec46f2f6fecf046f6b4e67c6ebc612030ccbd0f42c303cc675267374502ecb3e831c9bbfca0f13d339e31fb8933a99b7a SHA512 a258bf4f67db70263626ac77822afc75fd7a9e5af2feb1930314daff219865b28c43e82fef6ceae4f3f23957447d6eaebdc709e606d28457bca0f47eefb9274a
+DIST libqalculate-3.2.0.tar.gz 2035352 BLAKE2B 4ad9f1acaaa34693e3167514d16193b06af5a2d441946e636439cd9374c0061e0f20e72126a2cb020fed2e7c82e7144636a7eb545196bd6879af5a09320c3245 SHA512 6d0e1bbc1c9e4436208cd0ea855cc1d90b8a6d0525cd25bc9414db6e610e1e48aa84a9b552248926bd3c6f91db4997afb60658a5579502bac7194178e36fb857
diff --git a/sci-libs/libqalculate/libqalculate-3.2.0.ebuild b/sci-libs/libqalculate/libqalculate-3.2.0.ebuild
new file mode 100644
index 000000000000..807b7bed7d0b
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-3.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline static-libs"
+
+COMMON_DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with curl libcurl) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+
+ find "${ED}" -name '*.la' -delete || die
+}