summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-28 13:37:52 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-28 13:38:11 +0100
commit53130f4dd4f9b044616deb5bff4d34775f017add (patch)
treea054c898ee2362d80ed7e97590b70fcf006d2cc5 /sci-libs
parentgnome-extra/gnome-shell-frippery: Fix EmptyGlobalAssignment (diff)
downloadgentoo-53130f4dd4f9b044616deb5bff4d34775f017add.tar.gz
gentoo-53130f4dd4f9b044616deb5bff4d34775f017add.tar.bz2
gentoo-53130f4dd4f9b044616deb5bff4d34775f017add.zip
sci-libs/onnx: add 1.15.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/onnx-1.15.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 250b9b0f4797..7ba3f7c87091 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -3,3 +3,4 @@ DIST onnx-1.12.0.tar.gz 9531142 BLAKE2B 59117ea95e3686ca41c307f9ee35fbb3e9abc3b2
DIST onnx-1.13.1.tar.gz 10782133 BLAKE2B e5c93e00ccb73b56e839da48b255132f8c60508a258d136b53a2755caabed5f1b962208d570c71068484b269f016a08b398d6c8f4fc86d3850ad6d5742b760b6 SHA512 325859f591dece43a083a0945aefe3427bfdb68a98ef5922343bf7ed959528947e7664d6c8e3e3d35c390d6c20ef22d07c672e5311f80c72c199931be6c256c3
DIST onnx-1.14.0.tar.gz 11568979 BLAKE2B 9aed36489f0bbe0a96f2a7d3f44b70d228a7ec1239f5ba2b16f4b2c9ffa8fb1ddddba06b1b5e6d279d12f8d55eaeece6654da0c60220bf813e99df74e33a33eb SHA512 8a525b365fd203f0a59bcf82fa7f2e29d7e0563885ebe38269c596cd4eb949bcfc65d848b92b7abafa7ddecedcfc019f8779097ffcb5087f06037cace24462fc
DIST onnx-1.14.1.tar.gz 11570627 BLAKE2B df478219b5d557ad7e0717377996eefc02baa88a89d9681b17e00670e42fa3c8e47db0f5c5fdfab682fa7d80032559da8276c5106a91a7599d190427e2b6e4a8 SHA512 f846fffb286c4aeadc01462f220515f0a5c2ce1cbec849da7092a08c2676f8308af7315318a2866e9182f9aed719984ef95a9ddc69ffe0e62e40664395df5efd
+DIST onnx-1.15.0.tar.gz 12360484 BLAKE2B 4d35b82c128a69124b9bfcb3e56b3d584b7451ae739a91039e201dd485efa3e90e34e6cf135993317622f8f524160a38556231b2b0561e93d8cd0487abf35c1b SHA512 b46a4ab70af88053318eba45251c1f71528f15e45a33042877570e8d857febd3ec66e2e811fcda2105a4f17b84c9a1c6a0aaa22756c3287321b3ea29e83127fd
diff --git a/sci-libs/onnx/onnx-1.15.0.ebuild b/sci-libs/onnx/onnx-1.15.0.ebuild
new file mode 100644
index 000000000000..1e57c8b8213f
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.15.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_OPTIONAL=1
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="python"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ )
+ dev-libs/protobuf:=
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="python? (
+ ${DISTUTILS_DEPS}
+)"
+
+src_prepare() {
+ cmake_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ )
+ cmake_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use python && CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use python && distutils-r1_src_install
+}