summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-16 00:55:21 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-16 00:55:21 +0100
commit568a3b2d4c68eb44798da9d63fa15d82bee8b887 (patch)
tree5c059754490f825aa05e74831df5bf5ef567f95b /sci-libs
parentdev-lua/luafilesystem: QA: fix flag handling, add doc useflag (diff)
downloadgentoo-568a3b2d4c68eb44798da9d63fa15d82bee8b887.tar.gz
gentoo-568a3b2d4c68eb44798da9d63fa15d82bee8b887.tar.bz2
gentoo-568a3b2d4c68eb44798da9d63fa15d82bee8b887.zip
sci-libs/matio: Version bump to 1.5.17
Bug: https://bugs.gentoo.org/603218 Bug: https://bugs.gentoo.org/678816 Bug: https://bugs.gentoo.org/679476 Bug: https://bugs.gentoo.org/695314 Bug: https://bugs.gentoo.org/711822 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/Manifest1
-rw-r--r--sci-libs/matio/matio-1.5.17.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index 14a905b40bd0..586c116c3d40 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -1,2 +1,3 @@
DIST matio-1.5.13.tar.gz 10037903 BLAKE2B 8817fa3a1c050a84951c706922b32c5ed082ec057a35cb7fa20cc4d977316208a61604fcb6c0e09c96f592294a65d57a8a95844d15821987bdd337564345e778 SHA512 2db430dd47b8ceed850aaadf36c0fd3b405ba32db3eb2d5be320d007754983e2538ab99338d3ae8d69e8a531818c3bde0807c1f4a505eff7dd25d4a77934b737
DIST matio-1.5.16.tar.gz 10050153 BLAKE2B de643c11371a931853c2d60347431a1fc3c46f80d5e3083376e634999ea9d10bb1f5f547ed9844654dcb8ff6ff9492d037b26f693cbced04228a6c5d603c0a86 SHA512 38039ddc897b9e44677af08d996dde960355b6d8c5598000fbb23dda5501361d1c2a9e82f0f3e6c1309f0784943976259e5d39d1030f00db323e1756e5bd144a
+DIST matio-1.5.17.tar.gz 10066268 BLAKE2B 0852d1861bb4c43acd8a34d7114d29b7e15aa00e6f995d8516d22ff9420268cf7de7b82e08ee33978891bdfd02fcf3f8441aa1466e66e112a21f01abd6f3f0e0 SHA512 af8ff11c7c44fea9ea6886e381f49ef9186946f3def98ad9695f2d5d1df045c35e8f4ceac12a44be397f7bbd708b4803762b5ce54c45b60a9f446d551c04f5d2
diff --git a/sci-libs/matio/matio-1.5.17.ebuild b/sci-libs/matio/matio-1.5.17.ebuild
new file mode 100644
index 000000000000..da6218a96d9f
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.17.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="https://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/9" # subslot = soname version
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+ use doc && dodoc documentation/matio_user_guide.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc test/test*.c
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+
+ # no static archives
+ find "${D}" -name "*.la" -delete || die
+}