summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-02-12 14:36:28 -0500
committerSam James <sam@gentoo.org>2023-02-13 04:45:24 +0000
commit5888aff51b9e82fea2f5f0374b65f304a555aa89 (patch)
tree036c2e3ceb71f04c8e6105ee0bf30fc877d7eb74 /sci-libs
parentsys-apps/man-pages: add 6.03 (diff)
downloadgentoo-5888aff51b9e82fea2f5f0374b65f304a555aa89.tar.gz
gentoo-5888aff51b9e82fea2f5f0374b65f304a555aa89.tar.bz2
gentoo-5888aff51b9e82fea2f5f0374b65f304a555aa89.zip
sci-libs/libecpint: change C++ standard to C++14 and bump EAPI
The latest gtest now requires being built with the C++14 dialect or later. Change all references of C++11 to C++14 in several affected CMakeLists.txt files. Closes: https://bugs.gentoo.org/894044 Closes: https://github.com/gentoo/gentoo/pull/29561 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libecpint/libecpint-1.0.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/libecpint/libecpint-1.0.6-r1.ebuild b/sci-libs/libecpint/libecpint-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..6f56bf9ddced
--- /dev/null
+++ b/sci-libs/libecpint/libecpint-1.0.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Efficient evaluation of integrals over ab initio effective core potentials"
+HOMEPAGE="https://github.com/robashaw/libecpint"
+SRC_URI="https://github.com/robashaw/libecpint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/pugixml"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ find . -name CMakeLists.txt -exec \
+ sed -i -e 's/CXX_STANDARD 11/CXX_STANDARD 14/g' {} \; || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBECPINT_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}