summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-17 10:37:26 +0000
committerSam James <sam@gentoo.org>2024-03-17 10:41:46 +0000
commit5e0c88b630a733242dea94eae1a00e833d4242ee (patch)
tree07eef144b46ce565322fac77d456ca86ff105949 /sci-libs
parentdev-ruby/globalid: enable ruby33 (diff)
downloadgentoo-5e0c88b630a733242dea94eae1a00e833d4242ee.tar.gz
gentoo-5e0c88b630a733242dea94eae1a00e833d4242ee.tar.bz2
gentoo-5e0c88b630a733242dea94eae1a00e833d4242ee.zip
sci-libs/libint: add 2.9.0
Filter LTO given it's a tonne of code generating stuff and it takes hours to build. Filld with reinterpret_cast. Closes: https://bugs.gentoo.org/862894 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libint/Manifest1
-rw-r--r--sci-libs/libint/libint-2.9.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/libint/Manifest b/sci-libs/libint/Manifest
index f9aba9659d87..037fb5fba076 100644
--- a/sci-libs/libint/Manifest
+++ b/sci-libs/libint/Manifest
@@ -1,2 +1,3 @@
DIST libint-1.1.6.tar.gz 256404 BLAKE2B c754e25f0c3bc6c52eb434beafd2cb794a2e715003ee9409d76e8ae06e0ce19a42a9331ad4db9be2745d6820e7248210d10b4c004146e99192fd16fd2c31966d SHA512 cb39d73e89431c324e32d4a71593fe913c7ae2132677d4600e63ce1ed99e8e431758f0aa3d130991da841e98a1064fa931eb0e82dbe80af4c0ece10ee3a4f2d7
DIST libint-2.6.0.tar.gz 24743255 BLAKE2B 3ab7baba012828485c6c8425bce100e1ab50d2a3c8443ea2ef5cf173d58d8aa211a07e837b10a7f89d7e57f2e15b9384060bbf7b9885f32e9426525e65e15960 SHA512 56343c64b0dfb829702f4bb2fe14a04ad063acd7cb8b5a21cd1a45a830944c1ee98c888c9a28d6746b1bc17459aefcfb0aafe6ef310bfe554056212ad19e43ef
+DIST libint-2.9.0.tar.gz 21705777 BLAKE2B b2e8f36356f6eb8eff1207ba47c0f3bcc4471bd918cf933d03a1dd97efddd72d65464af743815d8bb633567ba97b19b8629881a5115b14f1630df1be7e6d0304 SHA512 6cffbd3d78dee4722b8085f4dd93085351cb610b5cb7ac090335adb2c43e87256ca06a658c202473fd763a38f7c0eeb6570b2c6a107e3f41d1258baf6e5b17de
diff --git a/sci-libs/libint/libint-2.9.0.ebuild b/sci-libs/libint/libint-2.9.0.ebuild
new file mode 100644
index 000000000000..f2d1c2fa4e39
--- /dev/null
+++ b/sci-libs/libint/libint-2.9.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic fortran-2 toolchain-funcs
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/gmp[cxx(+)]
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # bug 725454
+ sed -i -e '/RANLIB/d' src/bin/libint/Makefile || die
+}
+
+src_configure() {
+ # bug #862894
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ econf \
+ --with-cxx="$(tc-getCXX)" \
+ --with-cxx-optflags="${CXXFLAGS}" \
+ --with-cxxgen-optflags="${CXXFLAGS}" \
+ --with-cxxdepend="$(tc-getCXX)" \
+ --with-ranlib="$(tc-getRANLIB)" \
+ --with-ar="$(tc-getAR)" \
+ --with-ld="$(tc-getLD)" \
+ --enable-eri=2 --enable-eri3=2 --enable-eri2=2 \
+ --with-eri-max-am=7,5,4 --with-eri-opt-am=3 \
+ --with-eri3-max-am=7 --with-eri2-max-am=7 \
+ --with-g12-max-am=5 --with-g12-opt-am=3 \
+ --with-g12dkh-max-am=5 --with-g12dkh-opt-am=3 \
+ --enable-contracted-ints \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}