summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-01-02 12:42:27 -0600
committerMatthias Maier <tamiko@gentoo.org>2023-01-02 12:42:50 -0600
commit611d86f7df9ed465e8a98fd8000876bab2768f55 (patch)
treeaf5afbb944cbb9a35fcb889f6266d8570b8e7998 /sci-libs
parentdev-vcs/python-gitlab: add 3.12.0 (diff)
downloadgentoo-611d86f7df9ed465e8a98fd8000876bab2768f55.tar.gz
gentoo-611d86f7df9ed465e8a98fd8000876bab2768f55.tar.bz2
gentoo-611d86f7df9ed465e8a98fd8000876bab2768f55.zip
sci-libs/mumps: avoid a race condition
Closes: https://bugs.gentoo.org/889072 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mumps/mumps-5.3.5-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-libs/mumps/mumps-5.3.5-r1.ebuild b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
index 76020a68524a..7afc88c08537 100644
--- a/sci-libs/mumps/mumps-5.3.5-r1.ebuild
+++ b/sci-libs/mumps/mumps-5.3.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -145,7 +145,8 @@ src_compile() {
# Workaround #462602
export FAKEROOTKEY=1
- emake alllib PIC="-fPIC"
+ # Use "-j1" to avoid a spurious race condition
+ emake -j1 alllib PIC="-fPIC"
if ! use mpi; then
#$(tc-getAR) crs lib/libmumps_common.a libseq/*.o || die
LIBADD+=" -Llibseq -lmpiseq"