summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 00:04:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 01:14:25 +0200
commit6db9200aefab8f1d62f87d4a0ef20adc20bc4c12 (patch)
tree54e6a2d9a95d3ddf4801c7e965bb0b2215f00760 /sci-libs
parentmedia-libs/imlib: fix autotools patch filename (diff)
downloadgentoo-6db9200aefab8f1d62f87d4a0ef20adc20bc4c12.tar.gz
gentoo-6db9200aefab8f1d62f87d4a0ef20adc20bc4c12.tar.bz2
gentoo-6db9200aefab8f1d62f87d4a0ef20adc20bc4c12.zip
sci-libs/gdal: Fix build with Poppler 24.05
Upstream commit 60dcddbf5fab917338caf433b3e7dca283cf9720 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch23
-rw-r--r--sci-libs/gdal/gdal-3.8.5.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch b/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch
new file mode 100644
index 000000000000..837a50f6b825
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-3.8.5-poppler-24.05.0.patch
@@ -0,0 +1,23 @@
+From 60dcddbf5fab917338caf433b3e7dca283cf9720 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Thu, 4 Apr 2024 17:48:33 +0200
+Subject: [PATCH] Fix build with Poppler 24.05 (unreleased yet)
+
+---
+ frmts/pdf/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/frmts/pdf/CMakeLists.txt b/frmts/pdf/CMakeLists.txt
+index 9b9a1898a730..bcb19c3aa24c 100644
+--- a/frmts/pdf/CMakeLists.txt
++++ b/frmts/pdf/CMakeLists.txt
+@@ -54,6 +54,9 @@ if (GDAL_USE_POPPLER)
+ if ("${Poppler_VERSION_MINOR}" MATCHES "0?[0-9]+")
+ string(REGEX REPLACE "0?([0-9]+)" "\\1" Poppler_VERSION_MINOR ${Poppler_VERSION_MINOR})
+ endif ()
++ if (Poppler_VERSION_STRING VERSION_GREATER_EQUAL "24.05")
++ target_compile_features(gdal_PDF PRIVATE cxx_std_20)
++ endif ()
+ target_compile_definitions(gdal_PDF PRIVATE -DHAVE_POPPLER -DPOPPLER_MAJOR_VERSION=${Poppler_VERSION_MAJOR}
+ -DPOPPLER_MINOR_VERSION=${Poppler_VERSION_MINOR})
+ endif ()
diff --git a/sci-libs/gdal/gdal-3.8.5.ebuild b/sci-libs/gdal/gdal-3.8.5.ebuild
index bb1c2e0bde5e..3b40e02bfefc 100644
--- a/sci-libs/gdal/gdal-3.8.5.ebuild
+++ b/sci-libs/gdal/gdal-3.8.5.ebuild
@@ -101,6 +101,7 @@ QA_CONFIG_IMPL_DECL_SKIP=(
PATCHES=(
"${FILESDIR}"/${PN}-3.8.0-java21.patch
"${FILESDIR}"/${PN}-3.6.4-abseil-cpp-20230125.2-c++17.patch
+ "${FILESDIR}"/${P}-poppler-24.05.0.patch # in 3.9.0
)
pkg_setup() {