summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-07-07 12:15:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-07-07 12:27:24 +0200
commit6e4b5392287ab5e3698583059aeaf0dd38231c51 (patch)
treee667d7634f1eeeb05b0da5ae9bcb852972638893 /sci-libs
parentsci-misc/ViSP-images: bump to 3.5.0 (diff)
downloadgentoo-6e4b5392287ab5e3698583059aeaf0dd38231c51.tar.gz
gentoo-6e4b5392287ab5e3698583059aeaf0dd38231c51.tar.bz2
gentoo-6e4b5392287ab5e3698583059aeaf0dd38231c51.zip
sci-libs/ViSP: bump to 3.5.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ViSP/Manifest1
-rw-r--r--sci-libs/ViSP/ViSP-3.5.0.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/sci-libs/ViSP/Manifest b/sci-libs/ViSP/Manifest
index 45275696255a..c824b64e9e84 100644
--- a/sci-libs/ViSP/Manifest
+++ b/sci-libs/ViSP/Manifest
@@ -1 +1,2 @@
DIST visp-3.3.0.tar.gz 60822186 BLAKE2B 559698af352b4eac227ab2cdb8d66be31c04d2e2ac2d30ce07cef5022501162211ff9bfc9ed4970ac8b825321b8fc34241a6ca7a29b3d78fb70fa79ac429f7ab SHA512 f96b017353240e63059ef1e514a64198b6a50b95b5a08405c16e99589fd2110071e2d558921a674e538f9cdea07fde8e653ca630e3c12c38bf91f7a83057afe2
+DIST visp-3.5.0.tar.gz 52005297 BLAKE2B a429c07c8d80e8790bdd72bf27b777c79784173cc8be2539656c1cfbc111e35b3f80207a866fe3aaca536033af9e9d5006bf7e10a56cef5655aa9615a674c5ac SHA512 5a968a78c8ed2c48da71fa3def482b84fd73961f012e82ea1d7dd9b7b14336be5596ac9fc1bdf16414793d2399431bbc4306710d31b62946e6b2c03f692751b8
diff --git a/sci-libs/ViSP/ViSP-3.5.0.ebuild b/sci-libs/ViSP/ViSP-3.5.0.ebuild
new file mode 100644
index 000000000000..0dfc0c9751a2
--- /dev/null
+++ b/sci-libs/ViSP/ViSP-3.5.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Visual Servoing Platform: visual tracking and visual servoing library"
+HOMEPAGE="https://visp.inria.fr/"
+SRC_URI="https://visp-doc.inria.fr/download/releases/visp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/3.5"
+KEYWORDS="~amd64 ~arm"
+IUSE="
+ +coin demos +dmtx doc examples gsl ieee1394 jpeg motif ogre
+ opencv pcl png test tutorials usb v4l X xml +zbar zlib
+ cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3
+"
+REQUIRED_USE="motif? ( coin )"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ coin? (
+ >=media-libs/coin-4
+ virtual/opengl
+ )
+ dmtx? ( media-libs/libdmtx )
+ gsl? ( sci-libs/gsl:= )
+ ieee1394? ( media-libs/libdc1394:2= )
+ jpeg? ( virtual/jpeg:0 )
+ motif? ( media-libs/SoXt )
+ ogre? (
+ dev-games/ogre[ois(+)]
+ dev-libs/boost:=[threads(+)]
+ )
+ opencv? ( media-libs/opencv:=[contribdnn(+)] )
+ pcl? ( sci-libs/pcl:= )
+ png? ( media-libs/libpng:0= )
+ usb? ( virtual/libusb:1 )
+ v4l? ( media-libs/libv4l )
+ X? ( x11-libs/libX11 )
+ xml? ( dev-libs/libxml2 )
+ zbar? ( media-gfx/zbar )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${COMMON_DEPEND}
+ v4l? ( virtual/os-headers )"
+RDEPEND="${COMMON_DEPEND}
+ demos? ( sci-misc/ViSP-images )"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( sci-misc/ViSP-images )
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}/visp-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.0-ocv.patch"
+ "${FILESDIR}/${PN}-3.0.1-opencv.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_JAVA=OFF"
+ "-DBUILD_EXAMPLES=$(usex examples ON OFF)"
+ "-DBUILD_TESTS=$(usex test ON OFF)"
+ "-DBUILD_DEMOS=$(usex demos ON OFF)"
+ "-DBUILD_TUTORIALS=$(usex tutorials ON OFF)"
+ "-DUSE_COIN3D=$(usex coin ON OFF)"
+ "-DUSE_DC1394=$(usex ieee1394 ON OFF)"
+ "-DUSE_DMTX=$(usex dmtx ON OFF)"
+ "-DUSE_GSL=$(usex gsl ON OFF)"
+ "-DUSE_JPEG=$(usex jpeg ON OFF)"
+ "-DUSE_PNG=$(usex png ON OFF)"
+ "-DUSE_LIBUSB_1=$(usex usb ON OFF)"
+ "-DUSE_OGRE=$(usex ogre ON OFF)"
+ "-DUSE_OIS=$(usex ogre ON OFF)"
+ "-DUSE_OPENCV=$(usex opencv ON OFF)"
+ "-DUSE_PCL=$(usex pcl ON OFF)"
+ "-DUSE_SOQT=OFF"
+ "-DUSE_SOXT=$(usex motif ON OFF)"
+ "-DUSE_V4L2=$(usex v4l ON OFF)"
+ "-DUSE_X11=$(usex X ON OFF)"
+ "-DUSE_XML2=$(usex xml ON OFF)"
+ "-DUSE_ZBAR=$(usex zbar ON OFF)"
+ "-DUSE_ZLIB=$(usex zlib ON OFF)"
+ "-DCOIN3D_INCLUDE_DIR=${EPREFIX:-${SYSROOT}}/usr/include/Coin4"
+ "-DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)"
+ "-DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)"
+ "-DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile visp_doc
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ cmake_src_install
+ if use tutorials ; then
+ dodoc -r tutorial
+ docompress -x /usr/share/doc/${PF}/tutorial
+ fi
+}