summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-27 23:05:41 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-27 23:05:41 +0200
commit766ccf333003215d0b0d0fc3b86a84eb52a7feb4 (patch)
tree3334f79b6c5fb0dd2d3994b06b90cd891ac180c3 /sci-libs
parentsci-libs/hypre: Bump to 2.21.0 (diff)
downloadgentoo-766ccf333003215d0b0d0fc3b86a84eb52a7feb4.tar.gz
gentoo-766ccf333003215d0b0d0fc3b86a84eb52a7feb4.tar.bz2
gentoo-766ccf333003215d0b0d0fc3b86a84eb52a7feb4.zip
sci-libs/mpir: Port to EAPI 7, drop static-libs
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch4
-rw-r--r--sci-libs/mpir/mpir-3.0.0-r1.ebuild (renamed from sci-libs/mpir/mpir-3.0.0.ebuild)18
2 files changed, 10 insertions, 12 deletions
diff --git a/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch b/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch
index f02df55ccf98..100a6ae7088d 100644
--- a/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch
+++ b/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch
@@ -1,5 +1,5 @@
---- a/configure.ac 2009-11-28 10:48:59.196977657 +0000
-+++ b/configure.ac 2009-11-28 10:54:50.717976971 +0000
+--- a/configure.ac
++++ b/configure.ac
@@ -361,7 +361,7 @@
# hugely bloat the output.
diff --git a/sci-libs/mpir/mpir-3.0.0.ebuild b/sci-libs/mpir/mpir-3.0.0-r1.ebuild
index ccd38ea08c0d..eab814932b38 100644
--- a/sci-libs/mpir/mpir-3.0.0.ebuild
+++ b/sci-libs/mpir/mpir-3.0.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
@@ -12,14 +12,12 @@ SRC_URI="http://www.mpir.org/${P}.tar.bz2"
LICENSE="LGPL-3"
SLOT="0/23"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+cxx cpudetection static-libs"
+IUSE="+cxx cpudetection"
-DEPEND="
+BDEPEND="
x86? ( dev-lang/yasm )
amd64? ( dev-lang/yasm )
- amd64-fbsd? ( dev-lang/yasm )
"
-RDEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-2.7.2-ABI-multilib.patch
@@ -35,7 +33,7 @@ src_prepare() {
ebegin "Patching assembler files to remove executable sections"
local i
for i in $(find . -type f -name '*.asm') ; do
- cat >> $i <<-EOF
+ cat >> $i <<-EOF || die
#if defined(__linux__) && defined(__ELF__)
.section .note.GNU-stack,"",%progbits
@@ -44,7 +42,7 @@ src_prepare() {
done
for i in $(find . -type f -name '*.as') ; do
- cat >> $i <<-EOF
+ cat >> $i <<-EOF || die
%ifidn __OUTPUT_FORMAT__,elf
section .note.GNU-stack noalloc noexec nowrite progbits
@@ -62,16 +60,16 @@ src_configure() {
local myeconfargs=(
$(use_enable cxx)
$(use_enable cpudetection fat)
- $(use_enable static-libs static)
+ --disable-static
)
# https://bugs.gentoo.org/661430
if ! use amd64 && ! use x86; then
- myeconfargs+=( --with-yasm=/bin/false )
+ myeconfargs+=( --with-yasm="${BROOT}"/bin/false )
fi
econf "${myeconfargs[@]}"
}
src_install() {
default
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*la
+ find "${ED}" -name '*.la' -delete || die
}