summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-01-15 14:40:57 +1300
committerMichael Orlitzky <mjo@gentoo.org>2023-01-16 12:35:58 -0500
commit7a1d52341009e2cf2c218684bc7ff3da14e94118 (patch)
tree6cfe8a1aa169b700fd1dd8cf220a33b6478fa208 /sci-libs
parentdev-libs/newt: remove unused patches (diff)
downloadgentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.tar.gz
gentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.tar.bz2
gentoo-7a1d52341009e2cf2c218684bc7ff3da14e94118.zip
sci-libs/fplll: add 5.4.4
Closes: https://github.com/gentoo/gentoo/pull/29113 Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Signed-off-by: François Bissey <frp.bissey@gmail.com>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.4.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index b62b94d34a78..60af53390414 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1 +1,2 @@
DIST fplll-5.4.2.tar.gz 2618377 BLAKE2B e730c8646b9afb68515a23e533ea8ef833439d69f2130157bd6e38b1efab9116817535c261721c98b23410185271ffc323c687630e3ba262adb97fa5f69be787 SHA512 45324d89d0efeb269c1d1400332a51432e5d09f7bf0a6d651650e0941bb718493cbb66d65056b98691691236eaf348b2cae686ee06761f64380df98b6206c004
+DIST fplll-5.4.4.tar.gz 2630101 BLAKE2B b990c9346acd2c506b4697f27ff21d8453bb97473b2e988beb2ab9da34b3edd8a64d7558bca5f66a888fb4397c1e5340cf50f543ec580f0ec6980bc8c73a9390 SHA512 32a6515a3ab2677739a60a4ef0938e4284b5d3119a396104a7af22a6291ef669b42a4fb6e59f5c6daf97ff2402e7d035ea84fd1c76bfe7c0e17402bd03ae7166
diff --git a/sci-libs/fplll/fplll-5.4.4.ebuild b/sci-libs/fplll/fplll-5.4.4.ebuild
new file mode 100644
index 000000000000..d8ad2144d60b
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8"
+KEYWORDS="~amd64 ~x86"
+IUSE="qd"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0
+ qd? ( sci-libs/qd )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with qd)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}