summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-31 11:20:09 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-31 11:25:52 +0100
commit81a9e5bc3fae689a5d0e3ae28c31791b546b2682 (patch)
tree934a68cc6f948b4e6fbe42ad2a2b0631685e3508 /sci-libs
parentnet-misc/openssh: Merge "Drop special settings for Gentoo/FreeBSD 9.0" (diff)
downloadgentoo-81a9e5bc3fae689a5d0e3ae28c31791b546b2682.tar.gz
gentoo-81a9e5bc3fae689a5d0e3ae28c31791b546b2682.tar.bz2
gentoo-81a9e5bc3fae689a5d0e3ae28c31791b546b2682.zip
sci-libs/scipy: Correct tests to not fail on warning
Github: scipy/scipy#5426 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/scipy-0.16.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-libs/scipy/scipy-0.16.1.ebuild b/sci-libs/scipy/scipy-0.16.1.ebuild
index de2289b7e773..07d973074f97 100644
--- a/sci-libs/scipy/scipy-0.16.1.ebuild
+++ b/sci-libs/scipy/scipy-0.16.1.ebuild
@@ -119,9 +119,13 @@ python_test() {
"${PYTHON}" -c \
'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
|| die
+ # https://github.com/scipy/scipy/issues/5426
"${EPYTHON}" -c \
- "import scipy, sys; r = scipy.test('fast',verbose=2); sys.exit(0 if r.wasSuccessful() else 1)" \
+ "import scipy, sys; r = scipy.test('fast', verbose=2, raise_warnings='release'); sys.exit(0 if r.wasSuccessful() else 1)" \
|| die "Tests fail with ${EPYTHON}"
+# "${EPYTHON}" -c \
+# "import scipy, sys; r = scipy.test('fast',verbose=2); sys.exit(0 if r.wasSuccessful() else 1)" \
+# || die "Tests fail with ${EPYTHON}"
}
python_install_all() {