summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-18 16:43:46 +0000
committerSam James <sam@gentoo.org>2020-09-18 16:43:46 +0000
commit86f607c8a9fdb8858eacdeda23ea086857bf8131 (patch)
treef42351ff266294f1c54838622c3bc45738bb1f12 /sci-libs
parentsci-libs/mumps: minor ebuild surgery (diff)
downloadgentoo-86f607c8a9fdb8858eacdeda23ea086857bf8131.tar.gz
gentoo-86f607c8a9fdb8858eacdeda23ea086857bf8131.tar.bz2
gentoo-86f607c8a9fdb8858eacdeda23ea086857bf8131.zip
sci-libs/scotch: fix tests
Closes: https://bugs.gentoo.org/532620 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scotch/scotch-6.0.4-r2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/scotch/scotch-6.0.4-r2.ebuild b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
index 9f16ee0554d2..09ea23318f8d 100644
--- a/sci-libs/scotch/scotch-6.0.4-r2.ebuild
+++ b/sci-libs/scotch/scotch-6.0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,26 +7,28 @@ inherit eutils toolchain-funcs versionator flag-o-matic multilib
# use esmumps version to allow linking with mumps
MYP="${PN}_${PV}_esmumps"
-# download id on gforge changes every goddamn release
+# download id on gforge changes every release(!)
DID=34618
SOVER=$(get_major_version)
DESCRIPTION="Software for graph, mesh and hypergraph partitioning"
HOMEPAGE="http://www.labri.u-bordeaux.fr/perso/pelegrin/scotch/"
SRC_URI="http://gforge.inria.fr/frs/download.php/${DID}/${MYP}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
LICENSE="CeCILL-2"
SLOT="0/${SOVER}"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc int64 mpi static-libs tools threads"
+IUSE="doc int64 mpi static-libs test tools threads"
+# bug #532620
+REQUIRED_USE="test? ( threads )"
+RESTRICT="!test? ( test )"
DEPEND="
sys-libs/zlib
mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P/-/_}
-
static_to_shared() {
local libstatic=${1}; shift
local libname=$(basename ${libstatic%.a})