summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-27 23:05:23 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-27 23:05:23 +0200
commit8e369f73ed830f38516e689cc57527be94d7cce2 (patch)
treeea0754769d0816ea95ff02fb6144d6a6f7cbcb60 /sci-libs
parentsci-libs/cmpfit: Remove old 1.2-r1 (diff)
downloadgentoo-8e369f73ed830f38516e689cc57527be94d7cce2.tar.gz
gentoo-8e369f73ed830f38516e689cc57527be94d7cce2.tar.bz2
gentoo-8e369f73ed830f38516e689cc57527be94d7cce2.zip
sci-libs/cantera: Remove old 2.4.0-r5, 2.5.1
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/Manifest1
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r5.ebuild131
-rw-r--r--sci-libs/cantera/cantera-2.5.1.ebuild137
-rw-r--r--sci-libs/cantera/files/cantera-2.5.0_env.patch49
-rw-r--r--sci-libs/cantera/files/cantera_2.4.0_env.patch73
-rw-r--r--sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch17
-rw-r--r--sci-libs/cantera/files/cantera_2.4.0_sundials4.patch207
7 files changed, 0 insertions, 615 deletions
diff --git a/sci-libs/cantera/Manifest b/sci-libs/cantera/Manifest
index 6a29d4e0855a..67533340104e 100644
--- a/sci-libs/cantera/Manifest
+++ b/sci-libs/cantera/Manifest
@@ -1,2 +1 @@
-DIST cantera-2.4.0.tar.gz 2321316 BLAKE2B 40750e3864afa3d35817e6f5777a6ac235261e9d134ef749966dbd738a2af5efec2882e6dcc719851f88656b41469e2159d3bff3df32f6abdf57db3b0a2afcae SHA512 8bb0fee34fa5bc9ec78e6f21a100eaa77bdd966bd0b7f0fa27d452e4f122c69e61648beef847178490f5c5d56267a96f6081cac9ccd03cea153c32814e0e84e9
DIST cantera-2.5.1.tar.gz 2492422 BLAKE2B b48c5d12fc2b69d309759afd20b55dc2533c23ccba840109cf7a85c4ebb8306eb48d9f007914184a9d409f7bf296814fe09e6e62a29cf8384edd954fdff2af4e SHA512 8cd65f6b86b3009f22ec243cb7cb833e26919c4925fd15fba8fb98aad2180d8c0fe7550e13efeb7cce55abab06d9400230d59c9c43b4d3be6b0575b1164a56bc
diff --git a/sci-libs/cantera/cantera-2.4.0-r5.ebuild b/sci-libs/cantera/cantera-2.4.0-r5.ebuild
deleted file mode 100644
index 9e953bbc0bc4..000000000000
--- a/sci-libs/cantera/cantera-2.4.0-r5.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD=90
-
-inherit desktop fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="+cti fortran pch +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( cti )
- ${PYTHON_REQUIRED_USE}
- "
-
-RDEPEND="
- ${PYTHON_DEPS}
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')
- )
- <sci-libs/sundials-5.3.0:0=
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_MULTI_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.8.0
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}_${PV}_env.patch"
- "${FILESDIR}/${PN}_${PV}_env_python_install_prefix.patch"
- "${FILESDIR}/${PN}_${PV}_sundials4.patch"
-)
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-
-src_configure() {
- scons_vars=(
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++11"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch=$(usex pch)
-## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- python2_package="none"
- )
-
- if use cti ; then
- local scons_python=$(usex python full minimal)
- scons_targets+=( python3_package="${scons_python}" python3_cmd="${EPYTHON}" )
- else
- scons_targets+=( python3_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)" python3_prefix="$(python_get_sitedir)"
- if ! use cti ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}/$(python_get_sitedir)/${PN}"
- fi
-}
-
-pkg_postinst() {
- if use cti && ! use python ; then
- elog "Cantera was build without 'python' use-flag therefore the CTI tool 'ck2cti'"
- elog "will convert Chemkin files to Cantera format without verification of kinetic mechanism."
- fi
-
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-
- if use python ; then
- elog "Python examples are installed to '$(python_get_sitedir)/${PN}/examples/' directories."
- fi
-}
diff --git a/sci-libs/cantera/cantera-2.5.1.ebuild b/sci-libs/cantera/cantera-2.5.1.ebuild
deleted file mode 100644
index 71ba0f78c0f2..000000000000
--- a/sci-libs/cantera/cantera-2.5.1.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD="77 90"
-
-inherit desktop fortran-2 python-single-r1 scons-utils toolchain-funcs
-
-DESCRIPTION="Object-oriented tool suite for chemical kinetics, thermodynamics, and transport"
-HOMEPAGE="https://www.cantera.org"
-SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cti fortran pch +python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( cti )
- ${PYTHON_REQUIRED_USE}
-"
-
-RDEPEND="
- ${PYTHON_DEPS}
- python? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_MULTI_USEDEP}]
- ')
- )
- dev-cpp/yaml-cpp
- <sci-libs/sundials-5.3.0:0=
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/eigen:3
- dev-libs/boost
- dev-libs/libfmt
- python? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_MULTI_USEDEP}]
- ')
- )
- test? (
- >=dev-cpp/gtest-1.8.0
- python? (
- $(python_gen_cond_dep '
- dev-python/h5py[${PYTHON_MULTI_USEDEP}]
- dev-python/pandas[${PYTHON_MULTI_USEDEP}]
- ')
- )
- )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-2.5.0_env.patch" )
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-## Full list of configuration options of Cantera is presented here:
-## http://cantera.org/docs/sphinx/html/compiling/config-options.html
-src_configure() {
- scons_vars=(
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- cc_flags="${CXXFLAGS}"
- cxx_flags="-std=c++11"
- debug="no"
- FORTRAN="$(tc-getFC)"
- FORTRANFLAGS="${FCFLAGS}"
- optimize_flags="-Wno-inline"
- renamed_shared_libraries="no"
- use_pch=$(usex pch)
- ## In some cases other order can break the detection of right location of Boost: ##
- system_fmt="y"
- system_sundials="y"
- system_eigen="y"
- system_yamlcpp="y"
- env_vars="all"
- extra_inc_dirs="/usr/include/eigen3"
- )
- use test || scons_vars+=( googletest="none" )
-
- scons_targets=(
- f90_interface=$(usex fortran y n)
- )
-
- if use cti ; then
- local scons_python=$(usex python full minimal)
- scons_targets+=( python_package="${scons_python}" python_cmd="${EPYTHON}" )
- else
- scons_targets+=( python_package="none" )
- fi
-}
-
-src_compile() {
- escons build "${scons_vars[@]}" "${scons_targets[@]}" prefix="/usr"
-}
-
-src_test() {
- escons test
-}
-
-src_install() {
- escons install stage_dir="${D}" libdirname="$(get_libdir)" python_prefix="$(python_get_sitedir)"
- if ! use cti ; then
- rm -r "${D}/usr/share/man" || die "Can't remove man files."
- else
- # Run the byte-compile of modules
- python_optimize "${D}/$(python_get_sitedir)/${PN}"
- fi
-
- # We install static libs unconditionally here
- # See https://github.com/gentoo/gentoo/pull/10017#discussion_r229210565
-}
-
-pkg_postinst() {
- if use cti && ! use python ; then
- elog "Cantera was build without 'python' use-flag therefore the CTI tools 'ck2cti' and 'ck2yaml"
- elog "will convert Chemkin files to Cantera format without verification of kinetic mechanism."
- fi
-
- local post_msg=$(usex fortran "and Fortran " "")
- elog "C++ ${post_msg}samples are installed to '/usr/share/${PN}/samples/' directory."
-
- if use python ; then
- elog "Python examples are installed to '$(python_get_sitedir)/${PN}/examples/' directories."
- fi
-}
diff --git a/sci-libs/cantera/files/cantera-2.5.0_env.patch b/sci-libs/cantera/files/cantera-2.5.0_env.patch
deleted file mode 100644
index 9551d4b4ca1c..000000000000
--- a/sci-libs/cantera/files/cantera-2.5.0_env.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -Naur old/SConstruct new/SConstruct
---- old/SConstruct 2021-02-13 01:18:43.000000000 +0300
-+++ new/SConstruct 2021-02-13 01:27:06.000000000 +0300
-@@ -193,7 +193,7 @@
- toolchain = ['default']
-
- env = Environment(tools=toolchain+['textfile', 'subst', 'recursiveInstall', 'wix', 'gch'],
-- ENV={'PATH': os.environ['PATH']},
-+ ENV={'PATH': os.environ['PATH'], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')},
- toolchain=toolchain,
- **extraEnvArgs)
-
-@@ -724,10 +724,7 @@
- env['cantera_pure_version'] = re.match(r'(\d+\.\d+\.\d+)', env['cantera_version']).group(0)
- env['cantera_short_version'] = re.match(r'(\d+\.\d+)', env['cantera_version']).group(0)
-
--try:
-- env['git_commit'] = getCommandOutput('git', 'rev-parse', '--short', 'HEAD')
--except Exception:
-- env['git_commit'] = 'unknown'
-+env['git_commit'] = 'unknown'
-
- # Print values of all build options:
- print("Configuration variables read from 'cantera.conf' and command line:")
-diff -Naur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
---- old/interfaces/cython/SConscript 2021-02-13 01:18:43.000000000 +0300
-+++ new/interfaces/cython/SConscript 2021-02-13 01:59:29.000000000 +0300
-@@ -108,8 +108,7 @@
- elif localenv['libdirname'] != 'lib':
- # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${{python_prefix}}'
-- ' --install-lib=${{python_prefix}}/${{libdirname}}/python{}/site-packages'.format(py_version))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python_prefix}')
- else:
- extra = '--user'
- localenv.AppendENVPath(
-diff -Naur old/test_problems/SConscript new/test_problems/SConscript
---- old/test_problems/SConscript 2021-02-13 01:18:43.000000000 +0300
-+++ new/test_problems/SConscript 2021-02-13 01:42:19.000000000 +0300
-@@ -222,7 +222,7 @@
- CompileAndTest('VPsilane_test')
-
- CompileAndTest('clib', 'clib_test', 'clib_test',
-- extensions=['^clib_test.c'], libs=['cantera_shared'])
-+ extensions=['^clib_test.c'])
-
- # C++ Samples
- Test('cxx-bvp', 'cxx_samples', '#build/samples/cxx/bvp/blasius', None,
diff --git a/sci-libs/cantera/files/cantera_2.4.0_env.patch b/sci-libs/cantera/files/cantera_2.4.0_env.patch
deleted file mode 100644
index 8b0926f7b916..000000000000
--- a/sci-libs/cantera/files/cantera_2.4.0_env.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -Nur old/cantera-2.4.0/SConstruct new/cantera-2.4.0/SConstruct
---- old/SConstruct 2018-08-24 16:24:45.000000000 +0300
-+++ new/SConstruct 2019-07-17 15:50:06.000000000 +0300
-@@ -189,7 +189,7 @@
- toolchain = ['default']
-
- env = Environment(tools=toolchain+['textfile', 'subst', 'recursiveInstall', 'wix', 'gch'],
-- ENV={'PATH': os.environ['PATH']},
-+ ENV={'PATH': os.environ['PATH'], 'CCACHE_DIR': os.environ.get('CCACHE_DIR','')},
- toolchain=toolchain,
- **extraEnvArgs)
-
-@@ -327,6 +327,14 @@
- 'prefix',
- 'Set this to the directory where Cantera should be installed.',
- defaults.prefix, PathVariable.PathAccept),
-+ PathVariable(
-+ 'libdirname',
-+ """Set this to the directory where Cantera libraries should be installed.
-+ Some distributions (e.g. Fedora/RHEL) use 'lib64' instead of 'lib' on 64-bit systems
-+ or could use some other library directory name instead of 'lib' depends
-+ on architecture and profile (e.g. Gentoo 'libx32' on x32 profile).
-+ If user didn't set 'libdirname' configuration variable set it to default value 'lib'""",
-+ 'lib', PathVariable.PathAccept),
- EnumVariable(
- 'python_package',
- """If you plan to work in Python, then you need the ``full`` Cantera Python
-@@ -723,10 +731,7 @@
- env['cantera_pure_version'] = '.'.join(str(x) for x in ctversion.version)
- env['cantera_short_version'] = '.'.join(str(x) for x in ctversion.version[:2])
-
--try:
-- env['git_commit'] = getCommandOutput('git', 'rev-parse', '--short', 'HEAD')
--except Exception:
-- env['git_commit'] = 'unknown'
-+env['git_commit'] = 'unknown'
-
- # Print values of all build options:
- print("Configuration variables read from 'cantera.conf' and command line:")
-@@ -1061,7 +1066,7 @@
-
- # Ignore the minor version, e.g. 2.4.x -> 2.4
- env['sundials_version'] = '.'.join(sundials_version.split('.')[:2])
-- if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1'):
-+ if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2'):
- print("""ERROR: Sundials version %r is not supported.""" % env['sundials_version'])
- sys.exit(1)
- print("""INFO: Using system installation of Sundials version %s.""" % sundials_version)
-@@ -1465,12 +1470,6 @@
- # *** Set additional configuration variables ***
- # **********************************************
-
--# Some distributions (e.g. Fedora/RHEL) use 'lib64' instead of 'lib' on 64-bit systems
--if any(name.startswith('/usr/lib64/python') for name in sys.path):
-- env['libdirname'] = 'lib64'
--else:
-- env['libdirname'] = 'lib'
--
- # On Debian-based systems, need to special-case installation to
- # /usr/local because of dist-packages vs site-packages
- env['debian'] = any(name.endswith('dist-packages') for name in sys.path)
-diff -Nur old/cantera-2.4.0/test_problems/SConscript new/cantera-2.4.0/test_problems/SConscript
---- old/test_problems/SConscript 2018-08-24 16:24:45.000000000 +0300
-+++ new/test_problems/SConscript 2019-07-17 15:41:35.000000000 +0300
-@@ -282,7 +282,7 @@
- CompileAndTest('VPsilane_test', 'VPsilane_test', 'VPsilane_test', 'output_blessed.txt')
-
- CompileAndTest('clib', 'clib_test', 'clib_test', 'output_blessed.txt',
-- extensions=['^clib_test.c'], libs=['cantera_shared'])
-+ extensions=['^clib_test.c'])
-
- # Force explicitly-named tests to run even if SCons thinks they're up to date
- for command in COMMAND_LINE_TARGETS:
diff --git a/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch b/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch
deleted file mode 100644
index 838907996361..000000000000
--- a/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -Nur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
---- old/interfaces/cython/SConscript 2018-08-24 16:24:45.000000000 +0300
-+++ new/interfaces/cython/SConscript 2019-08-14 04:28:41.000000000 +0300
-@@ -83,10 +83,10 @@
- extra = ''
- elif localenv['OS'] == 'Darwin':
- extra = localenv.subst(' --prefix=${python%s_prefix}' % major)
-- elif localenv['libdirname'] == 'lib64':
-- # 64-bit RHEL / Fedora
-+ elif localenv['libdirname'] != 'lib':
-+ # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
- extra = localenv.subst(
-- ' --prefix=${python%s_prefix} --install-lib=${python%s_prefix}/lib64/python%s.%s/site-packages' % (major, major, major, minor))
-+ ' --prefix=${stage_dir}${prefix} --install-lib=${python%s_prefix}' % (major))
- else:
- extra = '--user'
- localenv.AppendENVPath(
diff --git a/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch b/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch
deleted file mode 100644
index 0b4d3abf8541..000000000000
--- a/sci-libs/cantera/files/cantera_2.4.0_sundials4.patch
+++ /dev/null
@@ -1,207 +0,0 @@
-diff -Naur a/SConstruct b/SConstruct
---- a/SConstruct 2020-04-21 13:55:06.000000000 +0300
-+++ b/SConstruct 2020-04-21 13:55:54.000000000 +0300
-@@ -1013,23 +1013,29 @@
-
- import SCons.Conftest, SCons.SConf
- context = SCons.SConf.CheckContext(conf)
--ret = SCons.Conftest.CheckLib(context,
-- ['sundials_cvodes'],
-- header='#include "cvodes/cvodes.h"',
-- language='C++',
-- call='CVodeCreate(CV_BDF, CV_NEWTON);',
-- autoadd=False,
-- extra_libs=env['blas_lapack_libs'])
--if ret:
-+
-+# Check initially for Sundials<=3.2 and then for Sundials>=4.0
-+for cvode_call in ['CVodeCreate(CV_BDF, CV_NEWTON);','CVodeCreate(CV_BDF);']:
-+ ret = SCons.Conftest.CheckLib(context,
-+ ['sundials_cvodes'],
-+ header='#include "cvodes/cvodes.h"',
-+ language='C++',
-+ call=cvode_call,
-+ autoadd=False,
-+ extra_libs=env['blas_lapack_libs'])
- # CheckLib returns False to indicate success
-+ if not ret:
-+ if env['system_sundials'] == 'default':
-+ env['system_sundials'] = 'y'
-+ break
-+
-+# Execute if the cycle ends without 'break'
-+else:
- if env['system_sundials'] == 'default':
- env['system_sundials'] = 'n'
- elif env['system_sundials'] == 'y':
- config_error('Expected system installation of Sundials, but it could '
- 'not be found.')
--elif env['system_sundials'] == 'default':
-- env['system_sundials'] = 'y'
--
-
- # Checkout Sundials submodule if needed
- if (env['system_sundials'] == 'n' and
-@@ -1066,13 +1072,14 @@
-
- # Ignore the minor version, e.g. 2.4.x -> 2.4
- env['sundials_version'] = '.'.join(sundials_version.split('.')[:2])
-- if env['sundials_version'] not in ('2.4','2.5','2.6','2.7','3.0','3.1','3.2'):
-+ sundials_ver = LooseVersion(env['sundials_version'])
-+ if sundials_ver < LooseVersion('2.4') or sundials_ver >= LooseVersion('6.0'):
- print("""ERROR: Sundials version %r is not supported.""" % env['sundials_version'])
- sys.exit(1)
- print("""INFO: Using system installation of Sundials version %s.""" % sundials_version)
-
- #Determine whether or not Sundials was built with BLAS/LAPACK
-- if LooseVersion(env['sundials_version']) < LooseVersion('2.6'):
-+ if sundials_ver < LooseVersion('2.6'):
- # In Sundials 2.4 / 2.5, SUNDIALS_BLAS_LAPACK is either 0 or 1
- sundials_blas_lapack = get_expression_value(['"sundials/sundials_config.h"'],
- 'SUNDIALS_BLAS_LAPACK')
-@@ -1690,7 +1697,7 @@
-
- if env['system_sundials'] == 'y':
- env['sundials_libs'] = ['sundials_cvodes', 'sundials_ida', 'sundials_nvecserial']
-- if env['use_lapack'] and LooseVersion(env['sundials_version']) >= LooseVersion('3.0'):
-+ if env['use_lapack'] and sundials_ver >= LooseVersion('3.0'):
- if env.get('has_sundials_lapack'):
- env['sundials_libs'].extend(('sundials_sunlinsollapackdense',
- 'sundials_sunlinsollapackband'))
-diff -Naur a/include/cantera/numerics/CVodesIntegrator.h b/include/cantera/numerics/CVodesIntegrator.h
---- a/include/cantera/numerics/CVodesIntegrator.h 2018-08-24 16:24:45.000000000 +0300
-+++ b/include/cantera/numerics/CVodesIntegrator.h 2020-04-21 13:55:54.000000000 +0300
-@@ -49,7 +49,6 @@
- m_maxord = n;
- }
- virtual void setMethod(MethodType t);
-- virtual void setIterator(IterType t);
- virtual void setMaxStepSize(double hmax);
- virtual void setMinStepSize(double hmin);
- virtual void setMaxSteps(int nmax);
-diff -Naur a/include/cantera/numerics/Integrator.h b/include/cantera/numerics/Integrator.h
---- a/include/cantera/numerics/Integrator.h 2018-08-24 16:24:45.000000000 +0300
-+++ b/include/cantera/numerics/Integrator.h 2020-04-21 13:55:54.000000000 +0300
-@@ -34,17 +34,6 @@
- Adams_Method //! Adams
- };
-
--//! Specifies the method used for iteration.
--/*!
-- * Not all methods are supported by all integrators.
-- */
--enum IterType {
-- //! Newton Iteration
-- Newton_Iter,
-- //! Functional Iteration
-- Functional_Iter
--};
--
- //! Abstract base class for ODE system integrators.
- /*!
- * @ingroup odeGroup
-@@ -163,11 +152,6 @@
- warn("setMethodType");
- }
-
-- //! Set the linear iterator.
-- virtual void setIterator(IterType t) {
-- warn("setInterator");
-- }
--
- //! Set the maximum step size
- virtual void setMaxStepSize(double hmax) {
- warn("setMaxStepSize");
-diff -Naur a/src/kinetics/ImplicitSurfChem.cpp b/src/kinetics/ImplicitSurfChem.cpp
---- a/src/kinetics/ImplicitSurfChem.cpp 2018-08-24 16:24:45.000000000 +0300
-+++ b/src/kinetics/ImplicitSurfChem.cpp 2020-04-21 13:55:54.000000000 +0300
-@@ -79,7 +79,6 @@
- // numerically, and use a Newton linear iterator
- m_integ->setMethod(BDF_Method);
- m_integ->setProblemType(DENSE + NOJAC);
-- m_integ->setIterator(Newton_Iter);
- m_work.resize(ntmax);
- }
-
-diff -Naur a/src/numerics/CVodesIntegrator.cpp b/src/numerics/CVodesIntegrator.cpp
---- a/src/numerics/CVodesIntegrator.cpp 2018-08-24 16:24:45.000000000 +0300
-+++ b/src/numerics/CVodesIntegrator.cpp 2020-04-21 13:55:54.000000000 +0300
-@@ -88,7 +88,6 @@
- m_type(DENSE+NOJAC),
- m_itol(CV_SS),
- m_method(CV_BDF),
-- m_iter(CV_NEWTON),
- m_maxord(0),
- m_reltol(1.e-9),
- m_abstols(1.e-15),
-@@ -218,17 +217,6 @@
- }
- }
-
--void CVodesIntegrator::setIterator(IterType t)
--{
-- if (t == Newton_Iter) {
-- m_iter = CV_NEWTON;
-- } else if (t == Functional_Iter) {
-- m_iter = CV_FUNCTIONAL;
-- } else {
-- throw CanteraError("CVodesIntegrator::setIterator", "unknown iterator");
-- }
--}
--
- void CVodesIntegrator::sensInit(double t0, FuncEval& func)
- {
- m_np = func.nparams();
-@@ -284,7 +272,11 @@
- //! Specify the method and the iteration type. Cantera Defaults:
- //! CV_BDF - Use BDF methods
- //! CV_NEWTON - use Newton's method
-- m_cvode_mem = CVodeCreate(m_method, m_iter);
-+ #if CT_SUNDIALS_VERSION < 40
-+ m_cvode_mem = CVodeCreate(m_method, CV_NEWTON);
-+ #else
-+ m_cvode_mem = CVodeCreate(m_method);
-+ #endif
- if (!m_cvode_mem) {
- throw CanteraError("CVodesIntegrator::initialize",
- "CVodeCreate failed.");
-@@ -394,7 +386,11 @@
- #if CT_SUNDIALS_VERSION >= 30
- SUNLinSolFree((SUNLinearSolver) m_linsol);
- SUNMatDestroy((SUNMatrix) m_linsol_matrix);
-- m_linsol_matrix = SUNBandMatrix(N, nu, nl, nu+nl);
-+ #if CT_SUNDIALS_VERSION < 40
-+ m_linsol_matrix = SUNBandMatrix(N, nu, nl, nu+nl);
-+ #else
-+ m_linsol_matrix = SUNBandMatrix(N, nu, nl);
-+ #endif
- #if CT_SUNDIALS_USE_LAPACK
- m_linsol = SUNLapackBand(m_y, (SUNMatrix) m_linsol_matrix);
- #else
-diff -Naur a/src/numerics/IDA_Solver.cpp b/src/numerics/IDA_Solver.cpp
---- a/src/numerics/IDA_Solver.cpp 2018-08-24 16:24:45.000000000 +0300
-+++ b/src/numerics/IDA_Solver.cpp 2020-04-21 13:55:54.000000000 +0300
-@@ -442,7 +442,11 @@
- #if CT_SUNDIALS_VERSION >= 30
- SUNLinSolFree((SUNLinearSolver) m_linsol);
- SUNMatDestroy((SUNMatrix) m_linsol_matrix);
-- m_linsol_matrix = SUNBandMatrix(N, nu, nl, nu+nl);
-+ #if CT_SUNDIALS_VERSION < 40
-+ m_linsol_matrix = SUNBandMatrix(N, nu, nl, nu+nl);
-+ #else
-+ m_linsol_matrix = SUNBandMatrix(N, nu, nl);
-+ #endif
- #if CT_SUNDIALS_USE_LAPACK
- m_linsol = SUNLapackBand(m_y, (SUNMatrix) m_linsol_matrix);
- #else
-diff -Naur a/src/zeroD/ReactorNet.cpp b/src/zeroD/ReactorNet.cpp
---- a/src/zeroD/ReactorNet.cpp 2018-08-24 16:24:45.000000000 +0300
-+++ b/src/zeroD/ReactorNet.cpp 2020-04-21 13:55:54.000000000 +0300
-@@ -28,7 +28,6 @@
- // numerically, and use a Newton linear iterator
- m_integ->setMethod(BDF_Method);
- m_integ->setProblemType(DENSE + NOJAC);
-- m_integ->setIterator(Newton_Iter);
- }
-
- void ReactorNet::setInitialTime(double time)