summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-24 17:03:46 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-24 21:02:07 +0200
commit8ee85fd0668f17101b4dd8ad1b35ee0194521184 (patch)
treee9ab50fe06687fc0954a5819634c673a38273f14 /sci-libs
parentsci-biology/eugene: Bump to 4.1d from science-overlay (diff)
downloadgentoo-8ee85fd0668f17101b4dd8ad1b35ee0194521184.tar.gz
gentoo-8ee85fd0668f17101b4dd8ad1b35ee0194521184.tar.bz2
gentoo-8ee85fd0668f17101b4dd8ad1b35ee0194521184.zip
sci-libs/libmems: Allow for compiling with GCC 6
Gentoo-bug: 594814 * Patch taken from Debian * Add sub-slot operator for dev-libs/boost * Delete .la files Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch18
-rw-r--r--sci-libs/libmems/libmems-1.6_p1-r2.ebuild (renamed from sci-libs/libmems/libmems-1.6_p1-r1.ebuild)27
2 files changed, 38 insertions, 7 deletions
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch b/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch
new file mode 100644
index 000000000000..bde8efeb4c9c
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch
@@ -0,0 +1,18 @@
+Description: Correct compilation with g++-6
+Author: Gert Wollny <gw.fossdev@gmail.com>
+Bug-Debian: https://bugs.debian.org/811870
+Forwarded: yes
+Bug: https://sourceforge.net/p/mauve/bugs/46/
+Last-Update: 2016-06-30
+
+--- a/libMems/ProgressiveAligner.cpp
++++ b/libMems/ProgressiveAligner.cpp
+@@ -1599,7 +1599,7 @@
+ c.SetLeftEnd(child_1, ancestral_matches[mI]->LeftEnd(1));
+ c.SetOrientation(child_1, ancestral_matches[mI]->Orientation(1));
+ c.SetLength(ancestral_matches[mI]->Length(1), child_1);
+- cga_list.push_back(make_tuple(c.Copy(), &bs[mI], ancestral_matches[mI]));
++ cga_list.push_back(boost::tuples::make_tuple(c.Copy(), &bs[mI], ancestral_matches[mI]));
+ }
+
+ stack<node_id_t> node_stack;
diff --git a/sci-libs/libmems/libmems-1.6_p1-r1.ebuild b/sci-libs/libmems/libmems-1.6_p1-r2.ebuild
index ac61e5455337..c00e615cd49b 100644
--- a/sci-libs/libmems/libmems-1.6_p1-r1.ebuild
+++ b/sci-libs/libmems/libmems-1.6_p1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,16 +12,15 @@ SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
SLOT="0"
LICENSE="GPL-2"
-IUSE="doc"
+IUSE="doc static-libs"
KEYWORDS="~amd64 ~x86"
-CDEPEND="
- dev-libs/boost
+RDEPEND="
+ dev-libs/boost:=
sci-libs/libgenome
sci-libs/libmuscle"
-DEPEND="${CDEPEND}
+DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-RDEPEND="${CDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-build.patch
@@ -29,9 +28,23 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc-4.7.patch
"${FILESDIR}"/${P}-broken-constness.patch
"${FILESDIR}"/${P}-format-security.patch
- )
+ "${FILESDIR}"/${P}-fix-c++14.patch
+)
src_prepare() {
default
eautoreconf
}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}