summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-30 15:29:32 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-30 15:37:38 -0500
commit8f672be663388bcc425aaaafb61e2799342395ef (patch)
tree54b5b8a67bfd6803d0d8ba205a4ff45232228a7b /sci-libs
parentdev-python/nltk: add missing dependencies (diff)
downloadgentoo-8f672be663388bcc425aaaafb61e2799342395ef.tar.gz
gentoo-8f672be663388bcc425aaaafb61e2799342395ef.tar.bz2
gentoo-8f672be663388bcc425aaaafb61e2799342395ef.zip
sci-libs/ginkgo: new package
This is a future reverse dependency of sci-libs/dealii Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ginkgo/Manifest1
-rw-r--r--sci-libs/ginkgo/ginkgo-1.1.1.ebuild44
-rw-r--r--sci-libs/ginkgo/ginkgo-9999.ebuild46
-rw-r--r--sci-libs/ginkgo/metadata.xml22
4 files changed, 113 insertions, 0 deletions
diff --git a/sci-libs/ginkgo/Manifest b/sci-libs/ginkgo/Manifest
new file mode 100644
index 000000000000..935ba5909f25
--- /dev/null
+++ b/sci-libs/ginkgo/Manifest
@@ -0,0 +1 @@
+DIST ginkgo-1.1.1.tar.gz 11787690 BLAKE2B 75c2c9b2d1e9ba00e3b0a20859af621cdf4aefe7c6e5ec9c7fc34a5368e5bee70d7d2b86ed9b2d9075ab7cc1a3334434fe20329d780f693be45fd7707cdbe27f SHA512 ab8f2d36453f4e60a4e0a13eddc4a137006c1cc6c9c0db00997dd721dfc06f4401109c5a22ba23a838206cff576d5041d06edaed8823006e69f11e360d1dadce
diff --git a/sci-libs/ginkgo/ginkgo-1.1.1.ebuild b/sci-libs/ginkgo/ginkgo-1.1.1.ebuild
new file mode 100644
index 000000000000..a3c8615833dc
--- /dev/null
+++ b/sci-libs/ginkgo/ginkgo-1.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical linear algebra software package"
+HOMEPAGE="https://ginkgo-project.github.io/"
+
+SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+IUSE=""
+
+# TODO: add slepc use flag once slepc is packaged for gentoo-science
+REQUIRED_USE=""
+
+RDEPEND=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s#\"lib\"#\"$(get_libdir)\"#g" \
+ -e "s#\"lib/#\"$(get_libdir)/#g" \
+ cmake/install_helpers.cmake || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DGINKGO_DEVEL_TOOLS=OFF
+ -DGINKGO_BUILD_TESTS=OFF
+ -DGINKGO_BUILD_BENCHMARKS=OFF
+ -DGINKGO_BUILD_REFERENCE=ON
+ -DGINKGO_BUILD_OMP=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/ginkgo/ginkgo-9999.ebuild b/sci-libs/ginkgo/ginkgo-9999.ebuild
new file mode 100644
index 000000000000..3b9102d21654
--- /dev/null
+++ b/sci-libs/ginkgo/ginkgo-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical linear algebra software package"
+HOMEPAGE="https://ginkgo-project.github.io/"
+
+inherit git-r3
+EGIT_REPO_URI="https://github.com/ginkgo-project/ginkgo"
+SRC_URI=""
+KEYWORDS=""
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+IUSE=""
+
+# TODO: add slepc use flag once slepc is packaged for gentoo-science
+REQUIRED_USE=""
+
+RDEPEND=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s#\"lib\"#\"$(get_libdir)\"#g" \
+ -e "s#\"lib/#\"$(get_libdir)/#g" \
+ cmake/install_helpers.cmake || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DGINKGO_DEVEL_TOOLS=OFF
+ -DGINKGO_BUILD_TESTS=OFF
+ -DGINKGO_BUILD_BENCHMARKS=OFF
+ -DGINKGO_BUILD_REFERENCE=ON
+ -DGINKGO_BUILD_OMP=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/ginkgo/metadata.xml b/sci-libs/ginkgo/metadata.xml
new file mode 100644
index 000000000000..e67b34570313
--- /dev/null
+++ b/sci-libs/ginkgo/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ginkgo is a high-performance linear algebra library for manycore
+ systems, with a focus on sparse solution of linear systems. It is
+ implemented using modern C++, with GPU kernels implemented in CUDA.
+ </longdescription>
+ <use>
+ </use>
+ <upstream>
+ <remote-id type="github">ginkgo-project/ginkgo</remote-id>
+ </upstream>
+</pkgmetadata>