summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2023-12-11 20:14:51 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-10 14:24:59 +0100
commit92c42a318e0f956e3cf42c8d1b6e4e24eeab3d5f (patch)
treec43c830ec6c3ac8e32ac384632ed5f8d79e2c51f /sci-libs
parentsci-geosciences/josm-bin: drop old (diff)
downloadgentoo-92c42a318e0f956e3cf42c8d1b6e4e24eeab3d5f.tar.gz
gentoo-92c42a318e0f956e3cf42c8d1b6e4e24eeab3d5f.tar.bz2
gentoo-92c42a318e0f956e3cf42c8d1b6e4e24eeab3d5f.zip
sci-libs/proj: add patch to install geotiff files
This patch is a backport of an upstream patch that will be applied in version 9.4.0 scheduled for March 01, 2024. Upstream: https://github.com/OSGeo/PROJ/pull/3970 Closes: https://bugs.gentoo.org/917393 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34242 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/proj/files/proj-geotiff.patch33
-rw-r--r--sci-libs/proj/proj-9.2.1-r1.ebuild (renamed from sci-libs/proj/proj-9.2.1.ebuild)6
-rw-r--r--sci-libs/proj/proj-9.3.0-r1.ebuild (renamed from sci-libs/proj/proj-9.3.0.ebuild)6
3 files changed, 43 insertions, 2 deletions
diff --git a/sci-libs/proj/files/proj-geotiff.patch b/sci-libs/proj/files/proj-geotiff.patch
new file mode 100644
index 000000000000..cef1faa4628f
--- /dev/null
+++ b/sci-libs/proj/files/proj-geotiff.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/917393
+https://github.com/OSGeo/PROJ/pull/3970
+
+From afccfb609db16524b602216d9dc2b55c154403bb Mon Sep 17 00:00:00 2001
+From: Marco Genasci <fedeliallalinea@gmail.com>
+Date: Sun, 26 Nov 2023 08:40:45 +0100
+Subject: [PATCH] Database: added ability to install *.tif if present in data
+
+---
+ data/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index 4cb89e7849..85ed6ba8d4 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -38,6 +38,8 @@ set(GRIDSHIFT_FILES ${GSB_FILES} ${GTX_FILES})
+
+ file(GLOB SCHEMA_FILES *.json)
+
++file(GLOB GEOTIFF_FILES *.tif)
++
+ set(ALL_SQL_IN "${CMAKE_CURRENT_BINARY_DIR}/all.sql.in")
+ set(PROJ_DB "${CMAKE_CURRENT_BINARY_DIR}/proj.db")
+ include(sql_filelist.cmake)
+@@ -107,6 +109,7 @@ set(ALL_DATA_FILE
+ ${GRIDSHIFT_FILES}
+ ${PROJ_DB}
+ ${SCHEMA_FILES}
++ ${GEOTIFF_FILES}
+ )
+ install(
+ FILES ${ALL_DATA_FILE}
diff --git a/sci-libs/proj/proj-9.2.1.ebuild b/sci-libs/proj/proj-9.2.1-r1.ebuild
index ac5e5df3f04d..50bbae86a419 100644
--- a/sci-libs/proj/proj-9.2.1.ebuild
+++ b/sci-libs/proj/proj-9.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,10 @@ DEPEND="
test? ( dev-cpp/gtest )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-geotiff.patch
+)
+
src_unpack() {
unpack ${P}.tar.gz
diff --git a/sci-libs/proj/proj-9.3.0.ebuild b/sci-libs/proj/proj-9.3.0-r1.ebuild
index d161662887a4..f605561280c2 100644
--- a/sci-libs/proj/proj-9.3.0.ebuild
+++ b/sci-libs/proj/proj-9.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,10 @@ DEPEND="
test? ( dev-cpp/gtest )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-geotiff.patch
+)
+
src_unpack() {
unpack ${P}.tar.gz