summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-20 15:15:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-20 15:17:44 +0200
commit9fb7fa411cc317988b890ae551aa1fce0e4155d6 (patch)
tree3f9da8bf44f1bea95aab70c98c6829a3af526241 /sci-libs
parentsci-visualization/pyxplot: Remove last-rited pkg (diff)
downloadgentoo-9fb7fa411cc317988b890ae551aa1fce0e4155d6.tar.gz
gentoo-9fb7fa411cc317988b890ae551aa1fce0e4155d6.tar.bz2
gentoo-9fb7fa411cc317988b890ae551aa1fce0e4155d6.zip
sci-libs/scipy-python2: Remove last-rited pkg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy-python2/Manifest2
-rw-r--r--sci-libs/scipy-python2/metadata.xml23
-rw-r--r--sci-libs/scipy-python2/scipy-python2-1.1.0.ebuild128
-rw-r--r--sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild129
4 files changed, 0 insertions, 282 deletions
diff --git a/sci-libs/scipy-python2/Manifest b/sci-libs/scipy-python2/Manifest
deleted file mode 100644
index f554d62f88c7..000000000000
--- a/sci-libs/scipy-python2/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST scipy-1.1.0.tar.gz 15583560 BLAKE2B 477753e622ee26a3bc8c2cb6829410152df84b29ce17a6d53a66348f5536f7993fedf5d32b782405b54b3af3feabf9bc91c381ed39546076849c2fdb71039404 SHA512 72fe32c6c009613cb78202598e5db14f8e630b3218839cfe18d43d40550d94cc5aa100c6f5d41f40e86ae148e9b6a13431bb91b0f9be44b0569ccd7b725fe973
-DIST scipy-1.2.3.tar.gz 23335997 BLAKE2B 183a0e8266a6fa08ca4fa05511d28f51a5ff9b3e8d00c24a355d2db00327eb973befbefbcf47cb288aafd60718db903ac29f775f519484a7c6d0919693c0a21f SHA512 d7739fa2f25689fc14ddf09477207c990b39b593a85f5c74687df1ffe097f6eee1bb2123aaa286189309f6d3b25cdd7757053d8b1008d1d6b3367a8e3a0a53b1
diff --git a/sci-libs/scipy-python2/metadata.xml b/sci-libs/scipy-python2/metadata.xml
deleted file mode 100644
index 2425e896a8a0..000000000000
--- a/sci-libs/scipy-python2/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- SciPy is an open source library of scientific tools for Python. SciPy
- supplements the popular numpy module, gathering a variety of high level
- science and engineering modules together as a single package.
- SciPy includes modules for graphics and plotting, optimization,
- integration, special functions, signal and image processing, genetic
- algorithms, ODE solvers, and others.
- </longdescription>
- <use>
- <flag name="sparse">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- </use>
- <upstream>
- <remote-id type="pypi">scipy</remote-id>
- <remote-id type="sourceforge">scipy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/scipy-python2/scipy-python2-1.1.0.ebuild b/sci-libs/scipy-python2/scipy-python2-1.1.0.ebuild
deleted file mode 100644
index 23d6871c6c37..000000000000
--- a/sci-libs/scipy-python2/scipy-python2-1.1.0.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
-
-MY_PN=${PN/-python2}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Scientific algorithms library for Python (py2 version)"
-HOMEPAGE="https://www.scipy.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="sparse test"
-RESTRICT="!test? ( test )"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- || (
- >=dev-python/numpy-python2-1.10[lapack,${PYTHON_USEDEP}]
- >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
- )
- sci-libs/arpack:0=
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack:0= )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- >=dev-python/cython-0.22[${PYTHON_USEDEP}]
- >=dev-python/setuptools-36[${PYTHON_USEDEP}]
- virtual/pkgconfig
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- !<sci-libs/scipy-1.4
- dev-python/pillow[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt THANKS.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF || die
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- # Drop hashes to force rebuild of cython based .c code
- rm cythonize.dat || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- # FIXME: parallel python building fails, bug #614464
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile \
- ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- "${PYTHON}" -c \
- 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
- || die
- "${EPYTHON}" -c \
- "import scipy, sys; r = scipy.test('fast', verbose=2); sys.exit(r)" \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild b/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild
deleted file mode 100644
index 05b35f960a41..000000000000
--- a/sci-libs/scipy-python2/scipy-python2-1.2.3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
-
-MY_PN=${PN/-python2}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Scientific algorithms library for Python (py2 version)"
-HOMEPAGE="https://www.scipy.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="sparse test"
-RESTRICT="!test? ( test )"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- || (
- >=dev-python/numpy-python2-1.10[lapack,${PYTHON_USEDEP}]
- >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
- )
- sci-libs/arpack:0=
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack:0= )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- >=dev-python/cython-0.22[${PYTHON_USEDEP}]
- >=dev-python/setuptools-36[${PYTHON_USEDEP}]
- virtual/pkgconfig
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-RDEPEND="${CDEPEND}
- !<sci-libs/scipy-1.4
- dev-python/pillow[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt THANKS.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF || die
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- # Drop hashes to force rebuild of cython based .c code
- rm cythonize.dat || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- # FIXME: parallel python building fails, bug #614464
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile \
- ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- "${PYTHON}" -c \
- 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
- || die
- "${EPYTHON}" -c \
- "import scipy, sys; r = scipy.test('fast', verbose=2); sys.exit(r)" \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
- python_optimize
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}