summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-02 13:41:53 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-02 14:00:39 +0200
commita14ca5337d196857025c27a5d51832a225323e83 (patch)
tree73fecb59df8950ea9cb90007d4e43e9ae9b81e46 /sci-libs
parentsci-chemistry/dssp: Take the package (diff)
downloadgentoo-a14ca5337d196857025c27a5d51832a225323e83.tar.gz
gentoo-a14ca5337d196857025c27a5d51832a225323e83.tar.bz2
gentoo-a14ca5337d196857025c27a5d51832a225323e83.zip
sci-libs/libcifpp: Bump to 1.1.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libcifpp/Manifest2
-rw-r--r--sci-libs/libcifpp/libcifpp-1.1.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/Manifest b/sci-libs/libcifpp/Manifest
index 3744a9f5c5d4..4085ab977164 100644
--- a/sci-libs/libcifpp/Manifest
+++ b/sci-libs/libcifpp/Manifest
@@ -1 +1,3 @@
+DIST components-1.1.1.cif.gz 80378687 BLAKE2B 0776d79f733762ad19177bc93a5587e90966a7862f84174ede23a5875ae4633b519168b24b1c02d7afb30f9049d48434921a70c097a7e8238a5745f1676dcc78 SHA512 fc68513b37871677beb60855e82ed5831e10b08340697a97bbc7113d4c898b8e8382d097d36793346e34b97f0b5def5312fe7eb81ab4f120ad3908ee8d6d1aa3
DIST libcifpp-1.0.1_p20210810.tar.gz 1308632 BLAKE2B 5ceacd1adfd75873266384d8f4f7dbd02737d4935c0506c54a925826b6c391950c68ad7174023894d3bf0f62e4d4d3790149f003113947e546bdd35b706d97b8 SHA512 7d9a914b032ac57992200b33968686dcf300230721aa96ae72fe23ce1ba403d8102eb7ba1819e6ab72b238f5d858c48da2d653540f33791d77d9d18cba275eb7
+DIST libcifpp-1.1.1.tar.gz 978553 BLAKE2B 750cf80bac769a3db86b3be03924402da0254e69206a15222a5dfaa23a7eadcac1f57eb054f2fc783c287bfed86dab0a75d2994b031cc3cd3c2431a26e250d17 SHA512 e74419dada21ea12423c404c34eeb0b410fdb0b26827cd4451375329668909879b6d4795451c6f7c2b2ffc8d282dfcff2f1800630a3487111404335be4cb338f
diff --git a/sci-libs/libcifpp/libcifpp-1.1.1.ebuild b/sci-libs/libcifpp/libcifpp-1.1.1.ebuild
new file mode 100644
index 000000000000..63a6e309a1b4
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake tmpfiles
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:0=[threads(+)]
+"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ mkdir data || die
+ cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DUSE_RSRC=OFF
+ -DCIFPP_BUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}