summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-03-21 18:32:22 +0100
committerAmy Liffey <amynka@gentoo.org>2018-03-21 18:44:11 +0100
commita6f1ed760f2dd6c44ba015479e32d8a8ac037370 (patch)
treec56bdecc98771960e24d49bae0aa02ecaa279c36 /sci-libs
parentsys-kernel/gentoo-sources: Linux patch 4.14.29 (diff)
downloadgentoo-a6f1ed760f2dd6c44ba015479e32d8a8ac037370.tar.gz
gentoo-a6f1ed760f2dd6c44ba015479e32d8a8ac037370.tar.bz2
gentoo-a6f1ed760f2dd6c44ba015479e32d8a8ac037370.zip
sci-libs/shapelib: version bump 1.4.1
Closes: https://bugs.gentoo.org/650946 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapelib/Manifest1
-rw-r--r--sci-libs/shapelib/shapelib-1.4.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/shapelib/Manifest b/sci-libs/shapelib/Manifest
index 89d22bc9441a..52b9b34c4b66 100644
--- a/sci-libs/shapelib/Manifest
+++ b/sci-libs/shapelib/Manifest
@@ -1 +1,2 @@
DIST shapelib-1.4.0.tar.gz 548990 BLAKE2B 0e75481d35f8dc5687eee23696d46a780d4b185a81ca1246e5c19f01e58f4a55dc7b69347c9effa01ac1786c5271dfe3907798cc81fe9314979c502bcb9d982d SHA512 206b81fe859a837e821e449ab1b2dbd5a3aa7abd1871da4aec69e130b6fad6300697429884ce359c90e4b76bca90e2108f32b9fdbd3b92013fa5a39f3bedeeb1
+DIST shapelib-1.4.1.tar.gz 549831 BLAKE2B e579704bd71c2525133f87628261e78f39e8063cd7e8a57997e90a8ca4a6ebb5de3a4d1ab8da5d00afe1363d9eb22e8c7a9a66ac109c300b72b6d26bd87b61fd SHA512 791c1a0d6c5ff09341176f68349ebd760ae91e8749a9f844299d7ac38a42c4f1131e63479c384a8a8b05a89e90d02e9fd92c526cab417eb80b171d639b4a4422
diff --git a/sci-libs/shapelib/shapelib-1.4.1.ebuild b/sci-libs/shapelib/shapelib-1.4.1.ebuild
new file mode 100644
index 000000000000..87fe28c275f3
--- /dev/null
+++ b/sci-libs/shapelib/shapelib-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating ESRI Shapefiles"
+HOMEPAGE="http://shapelib.maptools.org/"
+SRC_URI="http://download.osgeo.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/proj"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ rm -r m4/* || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --includedir=/usr/include/libshp
+}
+
+src_install() {
+ use doc && HTML_DOCS=( web/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
+}