summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-24 15:08:01 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-24 15:53:22 -0400
commita9bf4005be04a3bed6ebdcbb6737200c1362f2d7 (patch)
treee1a6e2894652a583466dd5081dc4498794c9d3b7 /sci-libs
parentsci-geosciences/gpsd: drop old EAPI=5 (diff)
downloadgentoo-a9bf4005be04a3bed6ebdcbb6737200c1362f2d7.tar.gz
gentoo-a9bf4005be04a3bed6ebdcbb6737200c1362f2d7.tar.bz2
gentoo-a9bf4005be04a3bed6ebdcbb6737200c1362f2d7.zip
sci-libs/coinor-cppad: drop old EAPI=5
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/coinor-cppad/Manifest1
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild51
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild51
3 files changed, 0 insertions, 103 deletions
diff --git a/sci-libs/coinor-cppad/Manifest b/sci-libs/coinor-cppad/Manifest
index 41262c6e3836..674756df5262 100644
--- a/sci-libs/coinor-cppad/Manifest
+++ b/sci-libs/coinor-cppad/Manifest
@@ -1,2 +1 @@
-DIST cppad-20140204.gpl.tgz 2189463 BLAKE2B 559162f45ebcb9cf11e0df5293430c5ce93c8993205c088639968ca52091a51e8d03a4e19a37d6c8e5949bc2b65f9eff7207d8e70f745e0c1748cb1dec963987 SHA512 0cead73e8d2e2da43ea22c003c0feccadefd2f66efbb58df45b79bff51181ad8646063fd053af8d377ce1732609c55175fd53c00142eb6635018878541f6d2ed
DIST cppad-20140519.gpl.tgz 2208236 BLAKE2B 5d53891ef3b458c3914f5d59f6656290be2811fbc84ca3f9bd253ce4620b1a4b00397e1beed694cdc5284a1f74441b68520b861c90d158c4eee11d1f8927b362 SHA512 8f47e545bc76f66edccb9ea083ddebcb5852fa1807d727b6e1f445ca74731e74f7614a1d33b48c6eafbc5129b319e513594b415ee838bdc634f9c00a6d9a22af
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild
deleted file mode 100644
index 77d4f5ebc898..000000000000
--- a/sci-libs/coinor-cppad/coinor-cppad-20140204.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYP=cppad-${PV}
-
-DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
-HOMEPAGE="https://projects.coin-or.org/CppAD/"
-SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- sci-libs/adolc:=
- sci-libs/ipopt:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )"
-
-S="${WORKDIR}/${MYP}"
-
-src_configure() {
- local myeconfargs=( $(use doc Documentation) )
- autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- ./build.sh doxygen || die
- fi
-}
-
-src_test() {
- autotools-utils_src_test check test
-}
-
-src_install() {
- use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r example/*
- fi
-}
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild
deleted file mode 100644
index 8294efcbd21d..000000000000
--- a/sci-libs/coinor-cppad/coinor-cppad-20140519.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYP=cppad-${PV}
-
-DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
-HOMEPAGE="https://projects.coin-or.org/CppAD/"
-SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- sci-libs/adolc:0=
- sci-libs/ipopt:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )"
-
-S="${WORKDIR}/${MYP}"
-
-src_configure() {
- local myeconfargs=( $(use doc Documentation) )
- autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- ./build.sh doxygen || die
- fi
-}
-
-src_test() {
- autotools-utils_src_test check test
-}
-
-src_install() {
- use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r example/*
- fi
-}