summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-14 08:44:04 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-14 08:45:00 +0100
commitb7cff97cf838c6c8f6b9f1a6220833372e86f6db (patch)
tree3642c5fd81bc7857c0f0625b960a46828847a297 /sci-libs
parentdev-db/timescaledb: drop 2.9.0, 2.9.1 (diff)
downloadgentoo-b7cff97cf838c6c8f6b9f1a6220833372e86f6db.tar.gz
gentoo-b7cff97cf838c6c8f6b9f1a6220833372e86f6db.tar.bz2
gentoo-b7cff97cf838c6c8f6b9f1a6220833372e86f6db.zip
sci-libs/onnx: add 1.12.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/onnx-1.12.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 7ff467655359..abc71ea28ca7 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -1 +1,2 @@
DIST onnx-1.11.0.tar.gz 9464979 BLAKE2B dfc8ab81d4776f806fa26c751c1eb1e19ea4cf9f0aa498880dc18eca160fdd9c43eda0077124ea7a674082e5ed93de7497411c48c3f9a12146905072e6477af6 SHA512 dc7045702188d7f40fead3ab6eccd8ff63357824c36873b415ad989d19aa952ff2c3758120de9050d84d92a35993198971be54ffa8e8d99fc70aa1b14b2ff73e
+DIST onnx-1.12.0.tar.gz 9531142 BLAKE2B 59117ea95e3686ca41c307f9ee35fbb3e9abc3b262943211a3c25f7ef3f89e3a185145f92c9dfc4108469a3bc4580a140de7c436f97a35e64902d5a6ed5ac8ab SHA512 ab0c4f92358e904c2f28d98b35eab2d6eac22dd0a270e4f45ee590aa1ad22d09e92b32225efd7e98edb1531743f150526d26e0cbdc537757784bef2bc93efa8e
diff --git a/sci-libs/onnx/onnx-1.12.0.ebuild b/sci-libs/onnx/onnx-1.12.0.ebuild
new file mode 100644
index 000000000000..ba196590ef22
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-libs/protobuf:="
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/patchelf
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ patchelf --set-soname libonnxifi.so "${ED}"/usr/lib/libonnxifi.so \
+ || die
+ mv "${ED}"/usr/lib/libonnxifi.so "${ED}"/usr/$(get_libdir)/libonnxifi.so \
+ || die
+}